[sword-devel] Is --enable-debug what I want?

Dmitrijs Ledkovs dmitrij.ledkov at gmail.com
Sat May 16 13:22:37 MST 2009

2009/5/16 Troy A. Griffitts <scribe at crosswire.org>:
> Dear Dmitrijs,
> Yes, --enable-debug is what you want.  New in 1.6.x, this flag turns on
> -Werror which means that warnings should be treated as errors.
> You can either fix the warnings, or turn off -Werror (should be easy to find
> in configure.ac)

As far as I remember all Debian Packages are compiled with -Wall
-Werror like always.

I'll try to bisect it. Cause 1.5.11 worked fine with the
--enable-debug. (Unless I'm wrong)

> Oddly, I build with debug turned on all using Jaunty and don't get this
> warning.  Maybe it's only on 32-bit systems?

Maybe it's something else?

Fail to build on Jaunty buildlogs:

AMD64: http://launchpadlibrarian.net/26795685/buildlog_ubuntu-jaunty-amd64.sword_1.6.0-1~30~09.04_FAILEDTOBUILD.txt.gz
i386: http://launchpadlibrarian.net/26795598/buildlog_ubuntu-jaunty-i386.sword_1.6.0-1~30~09.04_FAILEDTOBUILD.txt.gz
LPIA: http://launchpadlibrarian.net/26795548/buildlog_ubuntu-jaunty-lpia.sword_1.6.0-1~30~09.04_FAILEDTOBUILD.txt.gz

These are chroot environments, but I'm experiencing this on a regular
machine as well. I'll try to compile it by hand instead of using
debian packgaging and I'll see how far can I get with it.....

With best regards

Dmitrijs Ledkovs (for short Dima),
Ледков Дмитрий Юрьевич

More information about the sword-devel mailing list