[sword-devel] search failing in Hebrew modules

Troy A. Griffitts scribe at crosswire.org
Thu Jul 30 23:04:14 MST 2009

Nice attempt Matthew.  The issue here is that UTF8HebrewPoints is an 
OptionFilter type and thus has the ability to be in different modes 
(this one is simply On and Off) and the default for this particular 
filter is On.

Could you try a few things for me?  Could you try turning off Hebrew 
Vowel Points in Xiphos (I'm guess there is an option somewhere that 
allows turning on and off option filters) and then try your test again?


Matthew Talbert wrote:
> A little more information here. I added the line
> LocalStripFilter=UTF8HebrewPoints
> to the wlc.conf. (btw, there is no info on the wiki for this
> particular conf entry)
> Now, I made sure that StripText was getting called before doing the
> search. In addition, I am printing to the console the search term
> before and after calling StripText. Here's my output:
> ** Message: search term is מְאֹרֹת
> ** Message: search term now is מְאֹרֹת
> If that doesn't get messed up somehow, you should see that both terms
> have vowel points. I understood that StripText should remove the vowel
> points. Am I missing something somewhere?
> Matthew
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page

More information about the sword-devel mailing list