[sword-devel] osis2mod and ICU

Daniel Glassey dglassey at gmail.com
Tue Jan 27 15:10:13 MST 2009

On Tue, Jan 27, 2009 at 3:03 AM, Peter von Kaehne <refdoc at gmx.net> wrote:
> Peter von Kaehne wrote:
>> I tried several times compiling sword with ICU.
>> I have ICU and relevant devs installed.
>> I do not seem to attract any error messages
>> if I run osis2mod I get following message:
>> You are running osis2mod: $Rev: 2213 $
>> osis2mod is not compiled with support for ICU. Ignoring -n flag.
>> Note, that I am at the neewest of svn:
>> peter at peter-laptop:~/Downloads/Crosswire/sword$ svn up
>> At revision 2229.
>> What am i doing wrong?
>> Peter
> follow-up, experimenting with Matthew Talbert on osis2mod.cpp:
> Inserting of
> #define _ICU_ 1
> makes osis2mod capable of normalising.

That should be defined by configure if it is passed --with-icu

$ ./osis2mod
You are running osis2mod: $Rev: 2213 $

usage: /home/daniel/Repos/crosswire/sword/tmp/utilities/.libs/lt-osis2mod
<output/path> <osisDoc> [OPTIONS]

If you installed it you may have installed the lib to somewhere not in
your LD_LIBRARY_PATH the first time so it may have been using an old
non-compiledwithicu lib. Or something similar.

So works for me(tm)


More information about the sword-devel mailing list