[sword-devel] Cygwin GnomeSword

Chris Little chrislit at crosswire.org
Fri May 2 18:24:02 MST 2008

Starting from scratch, using a full, 2.75GB Cygwin install, following 
the instructions to the letter: While gtkhtml is compiling, it dies with 
the following error:

In file included from 
                  from /usr/include/libgnomeui-2.0/gnome.h:7,
                  from gtkhtml-embedded.c:25:
/usr/include/libgnomeui-2.0/libgnomeui/gnome-app-helper.h:781: error: 
parse error before '*' token
make[2]: *** [gtkhtml-embedded.lo] Error 1
make[2]: Leaving directory `/usr/src/Packages/gtkhtml-3.12.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/Packages/gtkhtml-3.12.2'
make: *** [all] Error 2

The build script just ignores all errors, so at the end, it does declare 
that GnomeSword is ready to use. But in truth, it hasn't been compiled.

I would guess that compiling gtkhtml 3.12.2 is no longer possible on an 
up to date Cygwin install (at least not without some patching). I recall 
using a later version fixed the issue, but I don't recall which version.


More information about the sword-devel mailing list