[sword-devel] Announcing FireBible 0.5.1 - GPLed Firefox font-end

Brian Fernandes infernalproteus at gmail.com
Sun Mar 30 15:48:19 MST 2008

>>  I'm also happy to hear that there are Linux 
>> installations on which it works out of the box.
> I obviously had already Java installed - which is not "out of the box"
> as such for Ubuntu, but simply a thing I did ages ago. But, yes, as such
> it works ootb.

Understood. I guess it will *not* work with Ubuntu ootb because it uses 
"gcj" (and not a Sun JRE) which AFAIK does include a Java plugin. GCJ is 
unsupported by FF anyway.

> Ah - stop - I forgot. I - dt my firefox settings could not install it
> directly from the website, but downloaded the extension to my desktop
> and dragged it into the Add-on window which I had opened. But again,
> this is what I normally do as have restrictive settings. Not sure how
> general it is.

If that is what you do normally, then it's good enough.

>> Do keep the feedback and bug reports coming. Next up would be support 
>> for more module types and some display preferences.
> where does it get its preferences from at the moment? BD?

Unfortunately, besides the two you have already seen, there are no other 
preferences right now. Everything else is JSword at defaults. FireBible 
is not aware of BD in anyway, only aware of JSword. I suggested a BD 
install because it already contains JSword and you can use BD to manage 
your modules, something FB is not currently capable of.


More information about the sword-devel mailing list