[sword-devel] Problems with imp2ld not responding

Alonso Graterol alonso.graterol at gmail.com
Tue Jan 8 18:02:46 MST 2008

   I tried svn (reported version 2128) but got some errors while compiling
so I left that alone and used sword-1.5.10
   After compile I ran ./imp2ld from within utilities subdirectory and
produced both .dat and .idx files OK. Also tried versions 1.5.8 & 1.5.9 and
both worked fine as well.
   I then installed 1.5.10 and tried again... got the loop.
   Rest of comments apply to version 1.5.10

As two people have the same problem I think it's time to use linux tools to
> analyse this.  Can you:
> 1. run ldd on your binary (ldd /.../bin/imp2ld) and post the output.

alonso:~/oneyearread$ ldd /usr/bin/imp2ld
        libsword-1.5.10.so =>
        libcurl.so.4 => /usr/lib/../lib/libcurl.so.4 (0x00002ba9bffa2000)
        libstdc++.so.6 => /usr/lib/../lib/libstdc++.so.6
        libz.so.1 => /lib/libz.so.1 (0x00002ba9c0503000)
        libm.so.6 => /usr/lib/../lib/libm.so.6 (0x00002ba9c071a000)
        libgcc_s.so.1 => /usr/lib/../lib/libgcc_s.so.1 (0x00002ba9c0999000)
        libc.so.6 => /usr/lib/../lib/libc.so.6 (0x00002ba9c0ba6000)
        libssh2.so.1 => /usr/lib/../lib/libssh2.so.1 (0x00002ba9c0ee7000)
        libldap-2.3.so.0 => /usr/lib/../lib/libldap-2.3.so.0(0x00002ba9c1109000)
        libssl.so.0.9.8 => /usr/lib/../lib/libssl.so.0.9.8
        libcrypto.so.0.9.8 => /usr/lib/../lib/libcrypto.so.0.9.8
        libdl.so.2 => /usr/lib/../lib/libdl.so.2 (0x00002ba9c18f6000)
        /lib/ld-linux-x86-64.so.2 (0x00002ba9bfa59000)
        liblber-2.3.so.0 => /usr/lib/../lib/liblber-2.3.so.0(0x00002ba9c1afb000)
        libresolv.so.2 => /usr/lib/../lib/libresolv.so.2

2. run the program with strace to reproduce the problem (strace -o
> /tmp/imp2ld.strace imp2ld [arg1] [...]).  Wait few seconds until you think
> it's looping, you can stop it with Ctrl-C.  Don't post the output file
> (/tmp/imp2ld.strace) in the list as it will probably huge, but use an free
> online service (like http://pastebin.com/ or if you can read french
> http://dl.free.fr/).  This file will display any system call and answer,
> allowing us to see I/O errors and things like that.

   Uhm... OK, I think I owe you an apologize.
   When I used strace as suggested I got a clean result as expected. Both
.dat & .idx files were produced well.
   The module Karl handed me use a sed instruction first and then calls
imp2ld. The loop goes on when I run this module. If I run imp2ld direct I
get no loop at all.
    I'll check if the reasons for which I needed this module still apply and
I will report back whatever I find.
    Thanks for your helpful and timely support.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.crosswire.org/pipermail/sword-devel/attachments/20080108/609bab80/attachment-0001.html 

More information about the sword-devel mailing list