[sword-devel] osis2mod warnings

DM Smith dmsmith555 at yahoo.com
Mon Dec 1 07:43:58 MST 2008

On Dec 1, 2008, at 9:21 AM, Chris Little wrote:

> David Haslam wrote:
>> I just wonder if all these "bugs" would be solved if we were not  
>> using an
>> Windows osis2mod build as old as June 2008.
> The June 2008 build of osis2mod corresponds to the Sword 1.5.11  
> release.
> I know that DM wants us to test and use the more recent SVN version,  
> but
> given that it isn't well tested it would not be appropriate to release
> it yet.
> I say this in part because I know there is a bug in the handling of
> introductions, introduced since 1.5.11, that needs to be addressed.  
> And
> I wouldn't be surprised if we discovered other problems, simply  
> because
> there have been so many changes since 1.5.11.

osis2mod released with 1.5.11 and what is currently under SVN will  
build modules that are 1.5.9 compatible. It is quite likely that newer  
OSIS documents will have constructs that the 1.5.9 engine does not  
handle or handle as well as a newer engine.

I think Chris's caveat is correct. The latest version in SVN does have  
one reported bug and may have more. But please see if it works with  
your module!


More information about the sword-devel mailing list