[sword-devel] mcount error on compile

Troy A. Griffitts scribe at crosswire.org
Sun Jan 14 18:30:10 MST 2007

	Here is my guess to add to the rest...

> g++ -DHAVE_CONFIG_H -I. -I. -I./include  -I ./include 
> -I/home/kevin/temp/biblesw/clucene-core-0.9.16a/src -I/opt/csw/lib 
> -L/opt/csw/lib -g3 -O0 -DCURLAVAILABLE -DUSELUCENE  -c -o buildtest.o 
> buildtest.cpp

Here we are compiling, and we are finding our header files for clucene 
under: /home/kevin/temp/biblesw/clucene-core-0.9.16a/src

> /bin/bash ./libtool --mode=link g++ -g3 -O0 -DCURLAVAILABLE 
> -DUSELUCENE   -I/home/kevin/temp/biblesw/clucene- core-0.9.16a/src 
> -I/opt/csw/lib -L/opt/csw/lib -o buildtest  buildtest.o 
> ./lib/libsword.la -lz  -lclucene

> Undefined                       first referenced
>  symbol                             in file
> _mcount                             /opt/csw//lib/libclucene.so

We are at the linking phase here (all compiling has succeeded, so all 
headers have been found), but notice location for libclucene.so.

 From this, my guess is that you may have different versions (or 
configured differently) of headers at 
/home/kevin/temp/biblesw/clucene-core-0.9.16a/src than you have for the 
installed library at /opt/csw//lib/libclucene.so

I would guess that you may want to rather include /opt/csw/include/ for 
the clucene stuff to be sure your headers are consistent with your library.

If you tried this and it failed, it was probably because clucene fails 
to install 1 include file (clucene-config.h, I believe).  They may have 
fixed it by now.  If now, the solution is simply to copy this from your 
src directory to you install directory (e.g.


Hope this helps,


More information about the sword-devel mailing list