[sword-devel] Sword SVN Compile Issues

Greg Hellings greg.hellings at gmail.com
Fri Sep 22 07:00:08 MST 2006

Fellow swords(wo)men,

I have been trying to compile the latest SVN (as of this morning - I believe
it's revision 1979) under Cygwin in Windows XP Pro.  I've noticed the
following oddities:

1) When configured with the command:
CC="gcc -mno-cygwin" CXX="g++ -mno-cygwin" ./usrinst.sh
and then executing the make results in errors in curlftpt.cpp complaining
about missing curl.h files.  Those files are included, but they are in
/usr/include/curl - right where they ought to be.

2) I then add CXXFLAGS=" -I/usr/include/ " to the environment variables at
the beginning of the userinst.sh execution and it brings up lots of errors
about the STL being undefined.  So I execute the configure script with the
--without-curl option and with the CXXFLAGS=" -I/usr/include " still there.

3) Now the system complains about missing sys/socket.h, netinet/in.h ,
netdb.h, arpa/inet.h in ftplib.o ... these files are also in /usr/include

4) So I go back and trace through the lib/Makefile and observe that maybe
CPPFLAGS is a better place to put the -I/usr/include and I rerun the command
CC="gcc -mno-cygwin" CXX="g++ -mno-cygwin" CPPFLAGS=" -I/usr/include "
./usrinst.sh --target=i686-pc-mingw32
so that I can see if it will pick up the curl headers.  It proceeds much
further than before but fails in file curlftpt.cpp still complaining about
undeclared parts of the stl vector class.

5) I then tried reconfiguring to tell system to compile with /usr/include in
the CPPFLAGS and with --without-curl enabled.  Now the build fails in
ftplib.c complaining about hundreds of redefined functions, macros and
variables within what appears to be a problem with recursively included

6) So I tried to compile it with just the native Cygwin tools by calling:
CPPFLAGS=" -I/usr/include " ./usrinst.sh
Now the compile fails in swmgr.cpp by calling
../include/utf8transliterator.h, which includes unicode/unistr.h and
unicode/translit.h - which it cannot find, as they are part of ICU, which I
cannot find available for Cygwin.

7) So then I tried to compile it with the native Cygwin tools but without
icu support by configuring wit
CPPFLAGS=" -I/usr/include " ./usrinst.sh --without-icu
Now the compile dies in swmodule.cpp because I am missing CLucene.h and its
attendant headers.

8) Then I tried to compile after configuring with the following options:
CPPFLAGS=" -I/usr/include " ./usrinst.sh --without-icu --without-lucene
This time the compile dies in the linking stage - probably because I had not
been doing a clean make inbetween my compilations, since they were all dying
in the compile stage.  So I re-pulled the SVN source and reconfigured and
compiled with the same options and the compile ran cleanly, but the link
returned a single message complaining about swobject.cpp having an undefined
reference to sword::stricmp(char const*, char const*) when attempting to
compile buildtest.exe

Any ideas where to proceed from here?

--Greg Hellings
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.crosswire.org/pipermail/sword-devel/attachments/20060922/1d5169c8/attachment.html 

More information about the sword-devel mailing list