[sword-devel] Sword 1.5.9 compilation problem

Linas S. mail at operis.org
Fri Oct 27 03:57:54 MST 2006

Thank you for the information. I succeded! Now I'm trying to compile on a  
different computer (SuSE 9.0). I get following error message:

./lib/.libs/libsword.a(zipcomprs.o)(.text+0x1a7): In function  
: undefined reference to `compress'
./lib/.libs/libsword.a(zipcomprs.o)(.text+0x2d3): In function  
: undefined reference to `uncompress'
collect2: ld returned 1 exit status
make[1]: *** [buildtest] Error 1
make: *** [all-recursive] Error 1

This time I disabled icu support in usrinst.h  but I think it isn't the  
reason for the error.

Linas Spraunius

On Tue, 24 Oct 2006 18:46:19 +0300, Karl Kleinpaste <karl at charcoal.com>  

> You need "icu" (International Components for Unicode).  In Fedora
> Core, this is available as:
> icu-3.4-6.2.i386.rpm
> libicu-3.4-6.2.i386.rpm
> libicu-devel-3.4-6.2.i386.rpm
> libicu-doc-3.4-6.2.i386.rpm
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page

Using Opera's revolutionary e-mail client: http://www.opera.com/m2/

More information about the sword-devel mailing list