[sword-devel] Problem compiling sword-1.5.9 on Fedora Core 5

Steven P. Ulrick lists-sword at afolkey2.net
Mon Oct 2 18:53:35 MST 2006

On Mon, 02 Oct 2006 18:33:52 -0700
"Troy A. Griffitts" <scribe at crosswire.org> wrote:

> Hey Steve,
>     Just a report.  I run an updated FC5 on my laptop and have no 
> trouble building with ICU support.  I'm guessing you might have
> multiple versions installed (installed manually, besides the ones in
> the FC5 yum repo) and are mixing headers and libs.  Hope this helps.
>     -Troy.

Hello, Troy
The only thing that I know of that uses icu on my system is Sword.  In
fact, I believe that it wasn't installed when I installed FC5 on our
system.  I actually had to "yum install" it just for the purpose of
compiling Sword.  The only attempts I made with other versions came
after the icu errors I posted to the sword-devel list earlier in this
thread.  Also, before I installed any other icu versions, I did rpm -qa
| grep icu and rpm -e on everything that came up.

Since "make" had just went into the "tests" directory in Sword
right before it bailed, I tried running usrinst.sh with
OPTIONS="--enable-tests $OPTIONS"
commented out.  This did eliminate the icu issue :)  But now "make"
bails thusly:

/usr/local/qt-src/include/private/qucomextra_p.h:87: warning: ‘struct QUType_varptr’ has virtual functions but non-virtual destructor
/bin/sh ../libtool --silent --mode=link --tag=CXX g++  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -g3 -fno-inline -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -fexceptions    -o bibletime  -L/usr/local/kde-svn-fc5/lib -L/usr/local/qt-src/lib -L/usr/lib    -L/usr/lib -L/usr/lib -R /usr/local/kde-svn-fc5/20061002-bibletime-1.6/lib -R /usr/local/kde-svn-fc5/lib -R /usr/local/qt-src/lib -R /usr/lib bibletime_init.o bibletime_slots.o bibletime.o bibletimeapp.o main.o bibletime_dcop.o bibletimeinterface_skel.o bibletime.moc.o  ./frontend/displaywindow/libdisplaywindow.a ./frontend/display/libdisplay.a ./frontend/keychooser/libkeychooser.a ./frontend/mainindex/libmainindex.a ./frontend/searchdialog/libsearchdialog.a ./frontend/libfrontend.a ./frontend/util/libfrontendutil.a ./backend/libbackend.a ./util/libutil.a -lXext -lqt-mt  -lz -lpng -lz -lm -lXext -lX11  -lSM -lICE -lpthread -lkdecore -lkdeui -lkdeprint -lkio -lkhtml -lX11  -lsword -lclucene
./frontend/libfrontend.a(cswordsetupdialog.o): In function `BookshelfManager::CSwordSetupDialog::slot_moduleRefreshProgressCancelClicked()':
/home/steve/CVS/Assorted-CVS-Modules/bibletime/bibletime/frontend/cswordsetupdialog.cpp:900: undefined reference to `sword::InstallMgr::terminate()'
./frontend/libfrontend.a(cswordsetupdialog.o): In function `BookshelfManager::CSwordSetupDialog::slot_installProgressCancelClicked()':
/home/steve/CVS/Assorted-CVS-Modules/bibletime/bibletime/frontend/cswordsetupdialog.cpp:893: undefined reference to `sword::InstallMgr::terminate()'
./frontend/libfrontend.a(btinstallmgr.o): In function `~BTInstallMgr':
/home/steve/CVS/Assorted-CVS-Modules/bibletime/bibletime/frontend/btinstallmgr.cpp:277: undefined reference to `sword::InstallMgr::terminate()'
/home/steve/CVS/Assorted-CVS-Modules/bibletime/bibletime/frontend/btinstallmgr.cpp:277: undefined reference to `sword::InstallMgr::terminate()'
/home/steve/CVS/Assorted-CVS-Modules/bibletime/bibletime/frontend/btinstallmgr.cpp:277: undefined reference to `sword::InstallMgr::terminate()'
./backend/libbackend.a(cswordbackend.o):(.rodata._ZTV13CSwordBackend[vtable for CSwordBackend]+0x28): undefined reference to `sword::SWMgr::AddStripFilters(sword::SWModule*, sword::multimapwithdefault<sword::SWBuf, sword::SWBuf, std::less<sword::SWBuf> >&, std::_Rb_tree_iterator<std::pair<sword::SWBuf const, sword::SWBuf> >, std::_Rb_tree_iterator<std::pair<sword::SWBuf const, sword::SWBuf> >)'
./backend/libbackend.a(cswordbackend.o):(.rodata._ZTV13CSwordBackend[vtable for CSwordBackend]+0x58): undefined reference to `sword::SWMgr::filterText(char const*, sword::SWBuf&, sword::SWKey const*, sword::SWModule const*)'
./backend/libbackend.a(cswordtreekey.o):(.rodata._ZTV13CSwordTreeKey[vtable for CSwordTreeKey]+0xd4): undefined reference to `sword::TreeKey::assureKeyPath(char const*)'
./backend/libbackend.a(bt_osishtml.o): In function `~BT_UserData':
/home/steve/CVS/Assorted-CVS-Modules/bibletime/bibletime/backend/bt_osishtml.h:30: undefined reference to `sword::OSISHTMLHREF::MyUserData::~MyUserData()'
/home/steve/CVS/Assorted-CVS-Modules/bibletime/bibletime/backend/bt_osishtml.h:30: undefined reference to `sword::OSISHTMLHREF::MyUserData::~MyUserData()'
collect2: ld returned 1 exit status
make[3]: *** [bibletime] Error 1
make[3]: Leaving directory `/home/steve/CVS/Assorted-CVS-Modules/bibletime/bibletime'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/steve/CVS/Assorted-CVS-Modules/bibletime/bibletime'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/steve/CVS/Assorted-CVS-Modules/bibletime'
make: *** [all] Error 2

So, since I "most likely" don't have multiple icu's hanging around, I
guess I will have to wait until next week when FC6 is released.
Compiling Sword & Bibletime will be the FIRST thing that I will do :)

Have a Great Night,
Steven P. Ulrick

 20:53:32 up 18 days,  4:19,  8 users,  load average: 1.14, 1.04, 0.98

More information about the sword-devel mailing list