[sword-devel] Compiling Sword

Moses Truong moses.truong at gmail.com
Mon Jul 24 21:47:19 MST 2006

OK, I've run
And that created the configure files...
but when I ran

I get the following error:
make[1]: Entering directory `/home/moses/sword/trunk'
/bin/sh ./libtool --tag=CXX --mode=link g++ -g3 -O0 -DCURLAVAILABLE -g 
-O2   -o buildtest  buildtest.o ./lib/libsword.la -lz
g++ -g3 -O0 -DCURLAVAILABLE -g -O2 -o buildtest buildtest.o  
./lib/.libs/libsword.a -licui18n -licuuc -licudata -lustdio -L/usr/lib 
/usr/lib/libcurl-gnutls.so -lgssapi_krb5 -lkrb5 -lk5crypto -lkrb5support 
-lcom_err -lresolv /usr/lib/libgnutls.so /usr/lib/libtasn1.so 
/usr/lib/libgcrypt.so -lnsl /usr/lib/libgpg-error.so /usr/lib/libidn.so 
-ldl -lz
/usr/bin/ld: cannot find -lustdio
collect2: ld returned 1 exit status
make[1]: *** [buildtest] Error 1

I tried to google lustdio, but couldn't find any solutions...
(I have libicu34-dev (3.4.1a-1ubuntu1) package installed)
> Moses,
> I first do:
> ./autoconfig.sh
> Carefully read the output. It may tell you to concat a file. Don't  
> remember exactly, but it is something like aclocal.m4.
> Then run ./usrinst.sh which will run configure for you.
> Hope this helps,
> 	DM

More information about the sword-devel mailing list