[sword-devel] Problem with '&' in NET bible

Barry Drake b.drake at ntlworld.com
Wed Jul 19 04:21:26 MST 2006

Hi there ........

I've just been taking a close look at the '&' problem that I mentioned 
on this list.  Moses Truong (who wrote the script that makes the NET 
modules) corrected a problem with the ampersand.  This only appears when 
Greek lexicon 'L&N' references are given.  However, this correction has 
given rise to another problem which I think may be Sword related.

In the NET bible module, in which the notes are displayed as footnotes, 
there is no problem.  In the NETnotes module, where the notes come as a 
commentary, the note truncates immediately before the '&'.

The raw text for the note at Revelation 22:3 appears in the raw module 
nt file as '<p><sup>9</sup> <b>tn</b>  Or "be anything accursed" (L&N 

This displays as: '9 tn  Or "be anything accursed" (L'  in the NETnotes 
commentary, but displays correctly as '9 tn  Or "be anything accursed" 
(L&N 33.474).' in the NET bible footnotes.  As this occurs with all of 
the frontends as far as I know, I take it something happens when an '&' 
is encountered in one of the filters in the library - presumably the 
footnotes are not filtered in the same way?.  Is there something we need 
to do to get the '&' and the text that follows it to appear? I suppose 
if all else fails, we could replace the ampersand with 'and', but L and 
N is a bit naff, don't you think?

God bless,


-- From Barry Drake (The Revd) minister of the Netherfield United Reformed church, Nottingham see http://www.jesusinnetherfield.org.uk for our church homepages).

Replies - b.drake at ntlworld.com

More information about the sword-devel mailing list