[sword-devel] Arabic Translation

See7a sameh.nabil at gmail.com
Fri May 6 17:37:21 MST 2005


I finally got arabic working in both locales and uilocales :) I'm
sending this mail to let you know the solution and also because I
think there should be some easier way to do it :)

The cause of the problems I had is the BOM hidden characters added in
the begining of the text file when I save it as utf8 in notepad. I
also tried another text editor with the same result. SWORD doesn't
seem to handle these charachters correctly. I just have open the file
in some editor that displays them and delete them manually to get it
to work.

Now it's just a matter of writing some Arabic string. I will send
again as soon as I have something completed.

I just wanted to know when is the next realease of SWORD for Windows
expected? I want to try to finish this translation - or at least a big
part of it - before the coming release so that it can be added to the
release package.


On 5/1/05, Joachim Ansorg <junkmail at joachim.ansorgs.de> wrote:
> Hi,
> > The files provided at
> > https://crosswire.org/svn/biblecs/trunk/stage/uilocales.d/ are encoded as
> > ascii though they have the Encoding value set ti utf8. Did anyone try
> > saving one of these files as utf8? Do we have any
> > working locales file that actually uses utf8 encoding?
> The de.conf file contains unicode umlaut characters.
> Is your arabic utf8 locale file available somewhere so we can test it?
> Joachim
> --
> <>< Re: deemed!

More information about the sword-devel mailing list