[sword-devel] pertaining xml2gbs, osis2mod

Chris Little chrislit at crosswire.org
Sat Jun 12 14:45:35 MST 2004

Benedykt P. Barszcz wrote:

>> Benedykt P. Barszcz wrote:
>> [...]  perhaps it's specified in the source file
>> somewhere..?
> What version of osisCore.xsd in the converter is being implemented right 
> now?
> I am able to use pollo editor with various versions of osisCore.xsd.
> Can I specify the version osis schema on the command line for the 
> xml2gbs converter?
> xml2gbs --schema-version=osisCore.2.0.1.xsd <osisfile> <module_name>
> I guess not, but it would be a nice feature....

We would only implement the latest version of OSIS (2.0.1, at the 
moment).  However, I don't think I have made any serious updates to 
xml2gbs since OSIS 1.1.1.  That said: there's NO difference.

If you're importing a non-Bible, it will not have <chapter> or <verse> 
elements, let alone milestone versions of them.  Its hierarchy will be 
expressed with <div> elements, that cannot be milestoned.  The additions 
of milestones was the big change from 1.1.1 to 1.5/2.0.

So just use the latest version of the OSIS specification along with the 
latest version of xml2gbs, and let us know if you actually have problems.


More information about the sword-devel mailing list