[sword-devel] proposed 1.5.7a

Daniel Glassey danglassey at ntlworld.com
Fri Jul 16 06:43:27 MST 2004

We are hopefully going to release a bugfix package for 1.5.7(better late
than never). A release candidate is at


It is identical to the source used to create the latest (just uploaded)
Debian packages.

It contains the fixes:
(1) change configure.ac to default to --without-lucene
(2) src/mgr/installmgr.cpp change TRUE to 1 since curl changed after we
(3) src/utilfns/utilstr.cpp change toupperstr and toupperstr_utf8 to do:
*buf++ = SW_toupper(*buf);
what it did before crashed if you compiled with -O2 with gcc 3.3 on
(4) include/multimapwdef.h change end() to this->end() so it will
compile with gcc 3.4
(5) run ./autogen.sh to regenerate the build system

Please test and report successes if it is ok (or if there are any
problems!) on other distributions.


More information about the sword-devel mailing list