[sword-devel] Error running "make" on CVS of Sword

Steven P. Ulrick sword-devel@crosswire.org
Mon, 17 Feb 2003 02:23:27 -0600

Hello, Everyone :)
While attempting to run "make" on the CVS of Sword, I got the following

Making all in .
make[2]: Entering directory `/home/steve/CVS/sword'
source='testlib.cpp' object='testlib.o' libtool=no \
depfile='.deps/testlib.Po' tmpdepfile='.deps/testlib.TPo' \
depmode=gcc3 /bin/sh ./depcomp \
g++ -DHAVE_CONFIG_H -I. -I. -I. -I ./include  -DUSBINARY  -g -O2
-ftemplate-depth-25 -c -o testlib.o `test -f 'testlib.cpp' || echo
/bin/sh ./libtool --mode=link g++  -g -O2 -ftemplate-depth-25   -o
testlib  testlib.o -L./lib -lsword -lz 
mkdir .libs
g++ -g -O2 -ftemplate-depth-25 -o testlib testlib.o 
-L/home/steve/CVS/sword/lib /home/steve/CVS/sword/lib/.libs/libsword.a
/home/steve/CVS/sword/lib/.libs/libsword.a(swmgr.o): In function
/home/steve/CVS/sword/lib/../src/mgr/swmgr.cpp:201: undefined reference
to `sword::OSISPlain::OSISPlain[in-charge]()'
collect2: ld returned 1 exit status
make[2]: *** [testlib] Error 1
make[2]: Leaving directory `/home/steve/CVS/sword'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/steve/CVS/sword'
make: *** [all] Error 2

Before I wrote the message, I ran "make disclean" and updated the CVS of
Sword, so the error message above is from my last attempt to "make"
Sword.  The two or three previous attempts had the same error.  I am
running Red Hat Linux 8 with all the official updates installed. 
Everything relating to building and compiling is either from the Red Hat
CD's, or from an official update.  And also, I installed EVERY package
from the Red Hat 8 CD's (Over 1440 of them :))

Thanks in advance for your help :)
Steven P. Ulrick