[sword-devel] Build problems with CVS

Scott Thomas sword-devel@crosswire.org
Wed, 9 Jan 2002 13:40:21 -0500

Sorry to sound lame, but I just recently joined the list and wanted 
to look at the code, and see where I might be able to volunteer (most 
likely testing or documentation, but who knows).

I immediately had two problems I can't resolve from the web info.

1. I followed the cvs (Linux) instructions and obtained the sword 
module. I ran ./configure fine, but when I tried to make I got as far 
as the keys directory when I got errors, as follows:

src/keys/versekey.cpp: In member function `virtual ListKey
   VerseKey::ParseVerseList(const char*, const char*, bool)':
src/keys/versekey.cpp:402: `isdigit' undeclared (first use this 
src/keys/versekey.cpp:402: (Each undeclared identifier is reported 
only once
   for each function it appears in.)
src/keys/versekey.cpp: In member function `VerseKey& 
src/keys/versekey.cpp:718: `isalpha' undeclared (first use this 
make[2]: *** [versekey.lo] Error 1
make[2]: Leaving directory `/space/docs/scott/Sword/sword'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/space/docs/scott/Sword/sword'
make: *** [all] Error 2

Have I missed something in the preparation for building?

2. On the web site (the URL I received in the email after joining the 
list) I tried to download a couple of the publicly locked modules 
from the Beta links, but all I got was the conf files. Is there 
another location where I should be looking for those modules?

Thanks in advance for any help.


On Wednesday 09 January 2002 07:57 am, Daniel Glassey wrote:
> I've commited everything I have at the moment including the files
> generated by autoconf/automake and everything works for me on a
> clean checkout. 'make install' need tweaked to install
> /etc/sword.conf and stuff, but apart from that the library builds
> and runs fine.
> hth,
> Daniel
> _________________________________________________________
> Do You Yahoo!?
> Get your free @yahoo.com address at http://mail.yahoo.com