[sword-devel] Sword Installation

Joachim Ansorg sword-devel@crosswire.org
Wed, 13 Feb 2002 12:03:05 +0100

Since I'm a developer of BibleTime I'd like to comment on this.

> Accordingly, one other thing
> worth considering is having the stable releases of Sword, GnomeSword, and
> BibleTime not be based on or require the latest development releases of
> various modules for each distribution (i.e., work out of the box or compile
> with the current releases of major distributions). The general user will
> probably set up their system, install their software, and not update their
> system until the next major release for their distribution is available.

This is right. The last few releases all required KDE 2.x, so they should 
work with almost all major distributions. BibleTime 1.1 will require KDE > 
2.1.x. I think this is ok, because KDE 2.0 was released a long time ago and 
all Linux distributions include KDE >= 2.1.
We try to require Sword's stable releases, to stay with an old Sword version 
isn't the right thing.

If I missed a point please point it out,