[sword-devel] 1.4.7 install on alpha page

DeMeulenaere, Darren sword-devel@crosswire.org
Wed, 31 May 2000 10:12:03 -0700

I am a little confused.  I downloaded sword-win32-1.4.7.exe and first tried
the -help, which gave me "usage: C:\\Windows\desktop\sword-win32-1.4.7.exe
<file.tar.gz> <outfile.exe> ["run command"]

You talk about using "xtarra.exe sword.tar.gz sword-win32-1.4.7.exe
"DiskImages/Disk1/setup.exe", but where do I get xtarra.exe.  I double
clicked on the sword-win32-1.4.7.exe and it ran a normal install. Though it
seems that nothing in installed.  

Also I tried doing an uninstall, and it looks like nothing was taken out or
uninstalled from Sword Project folder.


    I think we're about done.

    We needed a new self-extracting packager that would run our setup
program.  We have a new utility program we've dubbed: xtarra that will
take a tar.gz file and make it an executable self-extractor and
optionally store a command for execution after
decompression/extraction.  We've packaged the new 1.4.7 sword install
with it and it is up on the alpha site for testing.


    One feature that needs to still be implemented:  WE NEED TO CLEANUP
THE TEMP FILES.  Anyone have a good subroutine for deleting an entire
folder and all its contents/subfolders in WIN32?

You can try xtarra out for your own purposes.  It installs itself as the
stub of the .tar.gz file, so you should be able to run:
sword-win32-1.4.7.exe -help
and use this program to create your own self-extracting executables.
The command we use for a new sword install is:

xtarra.exe sword.tar.gz sword-win32-1.4.7.exe "Disk

If the install works correctly (and as soon as we add temp file
cleanup), I think we're ready to ship!