[sword-devel] Problems with Bible Time on RedHat 6.1

Joachim Ansorg sword-devel@crosswire.org
Tue, 30 Nov 1999 23:03:50 +0000


This is probably a solution.

A user got BibleTime working on RH 6.1 using the following options of the
configure script:

./configure --with-sworddir=<sworddir>  --with-qt-lib=<QT 1.4x -libs>
--qith-qt-includes=<QT 1.4x includes>

Hope this helps.

Hard to improve the installing script of BibleTime because the parts searching
for QT ar standard KDE.


>I am having problems getting a proper completion for configure on
>RedHat 6.1
>I am using the latest Sword (1.4.6) and Bible Time (0.2)
>Redhat 6.1 has KDE 1.1.2 and two versions of qt (1.44 and 2.0.1)
>The configure script can find the qt and kde libraries but there is a
>problem when a test compile is done saying to check whether the same
>compiler was used for qt and libkde.
>My initial thought was to try to get configure to use qt 2.0.1, but I
>know nothing about automake, nor about whether this would be biting off
>more than I can chew.   My initisl efforts cause different failures,
>that mean even less to me than the initial failure.
>What are some suggestions.
>1) To get BibleTime working for my personal use
>2) To determine what changes to BibleTime install procedures would be
>best for future use by the BibleTime project
>I know that these two may have different answers, and both are
>important to me.   However, for somewhat selfish reasons I would really
>like to get BibleTime working soon.
>... Darwin Gregory
>I am a creationist.
>You can be too, just check out the facts!
>Do You Yahoo!?
>Thousands of Stores.  Millions of Products.  All in one place.
>Yahoo! Shopping: http://shopping.yahoo.com
BibleTime - the bible study program for KDE