[bt-devel] 2.8.3 compile error with Qt 4.5.3

Gary Holmlund gary.holmlund at gmail.com
Wed Nov 23 08:04:06 MST 2011

On 11/23/2011 01:35 AM, Jaak Ristioja wrote:
> Hash: SHA1
> On 23.11.2011 02:40, Jaak Ristioja wrote:
>> On 23.11.2011 01:09, cricketc at gmail.com wrote:
>>> Hello,
>>> I'm getting an error with 2.8.3 - "const class QDateTime has no member named
>>> 'currentMSecsSinceEpoch'". I'm using Qt 4.5.3, and 2.8.2 worked fine. I looked
>>> the error up, and it looks like this function was introduced in Qt 4.7.
>>> Is that correct? Was it intentional to increase the Qt required version to
>>> 4.7?
>> Hi!
>> It was not intentional, it was my error. Thanks for reporting this! I'll
>> try to release 2.8.4 as soon as possible. I guess this bug is also
>> present in 2.9_rc2.
> We've released 2.8.4 where I removed the call to currentMSecsSinceEpoch.
> However I didn't have time to actually test whether it compiles against
> Qt 4.5.
> I'm using Qt Creator for development, and I know that in principle it
> supports switching the Qt version against which to build qmake projects.
> I'm not sure whether the same thing works with CMake-based projects like
> BibleTime.
> Before I find time to try it myself I'd like to ask whether any of you
> have tried to build CMake-based projects against different versions of
> Qt? Was it easy to set up?
> - --
> Blessings,
> Jaak

If you change your PATH so that the qmake program of the Qt version you 
want is first in the PATH, and then run cmake it will build with that 
Qt. You can check the output of cmake to make sure which version of Qt 
is used.

Also, I just build stable-2.8 on ubuntu 10.04 with Qt 4.6.2 and it 
worked fine.


More information about the bt-devel mailing list