[bt-devel] Bibletime 2.9.1-1 packages uploaded to developer-testing PPA

Jonathan Marsden jmarsden at fastmail.fm
Sun Dec 25 13:47:59 MST 2011


On 12/25/2011 04:56 AM, Barry Drake wrote:

> On 24/12/11 23:17, Jonathan Marsden wrote:

>> How exactly did you install the bibletime 2.9.1-1 packages? Did
>> you install the bibletime-data 2.9.1-1 package as well as the 
>> bibletime-2.9.1-1 package?

> That was the problem.  I removed the bibletime-data package and the 
> bibletime package and re-installed.  Problem solved.  I think it
> would be as well to check the bibletime-data version when installing.

Agreed, thanks for finding the issue.  This kind of thing is what
developer-testing is for.

This is already fixed in newer packages that are now in the
developer-testing repository (uploaded yesterday).  They now have a
*versioned* dependency from bibletime to bibletime-data, so installing
the bibletime package should now also install the exactly corresponding
version of bibletime-data.

Now we get:

  dpkg-deb -f bibletime_2.9.1-1_amd64.deb Depends

  libc6 (>= 2.4), libclucene0ldbl (>= 0.9.21b), libcurl3-gnutls (>= 7.16.2-1), libgcc1 (>= 1:4.1.1), libicu42 (>= 4.2-1), libqt4-dbus (>= 4:4.5.3), libqt4-network (>= 4:4.5.3), libqt4-webkit (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqt4-xmlpatterns (>= 4:4.5.3), libqtcore4 (>= 4:4.6.1), libqtgui4 (>= 4:4.6.1), libstdc++6 (>= 4.4.0), libsword8 (>= 1.6), zlib1g (>= 1:1.1.4), libqt4-svg (>= 4.4.0), bibletime-data (= 2.9.1-1)

which will hopefully avoid the possibility of mismatched bibletime and
bibletime-data packages from now on.

(I led worship at our Spanish service on Christmas Eve -- 7pm service
with lots of food / party following... then I was back at 8:30am for
worship practice before leading worship in the English service this

Merry Christmas!


More information about the bt-devel mailing list