[bt-devel] Bibletime 2.9.1-1 packages uploaded to developer-testing PPA

Jonathan Marsden jmarsden at fastmail.fm
Sat Dec 24 17:12:21 MST 2011

On 12/24/2011 03:38 PM, Greg Hellings wrote:

> Does the bibletime package specify bibletime-data as a dependency at
> least?  Having not used a packaged version in ages, I guess I haven't
> really kept up.

It certainly should.  Checking:

  jonathan at black:~/pbuilder/precise_result$ dpkg-deb -I bibletime_2.9.1-1_amd64.deb |grep Depends:
  Depends: libc6 (>= 2.4), libclucene0ldbl (>= 0.9.21b), libgcc1 (>= 1:4.1.1), libqt4-dbus (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.6.1), libqtwebkit4 (>= 2.2~2011week36), libstdc++6 (>= 4.6), libsword8 (>= 1.6.2+dfsg), libqt4-svg (>= 4.4.0), bibletime-data

shows that we have a dependency on bibletime-data, but it is
unversioned.  So, if somehow an older package of bibletime-data already
was installed, and the new bibletime 2.9.1-1 package was installed in
some non-standard way, it may not force the "same version" of
bibletime-data to be installed.  Perhaps it should.

That is why I asked for details on exactly how bibletime 2.9.1-1 was
installed, and on exactly what bibletime-related packages we had on
Barry's machine.

Clearly, something didn't go right, but apparently it isn't just that
"the new packages don't have the right files in them" -- it might be
some kind of user error during the installation, or there could be a bug
in my packaging.


More information about the bt-devel mailing list