mvnForum Homepage Welcome Guest  | Guest Setting  |  Register  |   Login
  Search  
Index  | Recent Threads  | Unanswered Threads  | Who's Online  | User List  | Help


»

No member browsing this thread
Thread Status: Active
Total posts in this thread: 19
Posts: 19   Pages: 2   [ Previous Page | 1 2 ]
Post new Thread
Author
Previous Thread This topic has been viewed 3915 times and has 18 replies Next Thread
Male iGreg
Regular



USA
Joined: Oct 19, 2009
Post Count: 10
Status: Offline
Reply to this Post  Reply with Quote 
Re: Search not working at all in v.2 beta

Deleting those files seems to have fixed it.

Searching works now.
[Oct 28, 2009 7:42:32 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male iGreg
Regular



USA
Joined: Oct 19, 2009
Post Count: 10
Status: Offline
Reply to this Post  Reply with Quote 
Re: Search not working at all in v.2 beta

I spoke to soon.

It stopped working again.
[Oct 28, 2009 7:45:08 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male iGreg
Regular



USA
Joined: Oct 19, 2009
Post Count: 10
Status: Offline
Reply to this Post  Reply with Quote 
Re: Search not working at all in v.2 beta

The spinning beachball appears and I have to force quit Macsword.
[Oct 28, 2009 7:48:14 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male mdbergmann
Inventory
Member's Avatar

Germany
Joined: Jun 12, 2008
Post Count: 640
Status: Offline
Reply to this Post  Reply with Quote 
Re: Search not working at all in v.2 beta

So it worked once and you got search results.
But then searching again on the same module didn't work?


Manfred
[Oct 29, 2009 1:33:47 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
Male iGreg
Regular



USA
Joined: Oct 19, 2009
Post Count: 10
Status: Offline
Reply to this Post  Reply with Quote 
Re: Search not working at all in v.2 beta

I used KJV Bible and it was ok.

Then tried it on Matthew Henry Commentary and it stopped working for everything, including KJV
[Oct 29, 2009 5:01:10 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male mdbergmann
Inventory
Member's Avatar

Germany
Joined: Jun 12, 2008
Post Count: 640
Status: Offline
Reply to this Post  Reply with Quote 
Re: Search not working at all in v.2 beta

I used KJV Bible and it was ok.

Then tried it on Matthew Henry Commentary and it stopped working for everything, including KJV

Could you please send me the MacSword2.log file located in ~/Library/Logs.
Maybe it contains a hint of a problem.
You could try disabling the background indexer. Maybe there is a problem with it and I'll through another test round when I have my Mac back from repair.


Manfred
[Oct 30, 2009 1:22:46 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
Male mdbergmann
Inventory
Member's Avatar

Germany
Joined: Jun 12, 2008
Post Count: 640
Status: Offline
Reply to this Post  Reply with Quote 
Re: Search not working at all in v.2 beta

Greg.

I don't know what exactly happens on your computer but according to the logs there seem to be problems on index creation.
Can't tell right now much more.

I would suggest that disable background indexing and remove the index folder again. Then have the index created on-the-fly and see if that works.


Manfred
[Nov 2, 2009 2:00:31 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
Male iGreg
Regular



USA
Joined: Oct 19, 2009
Post Count: 10
Status: Offline
Reply to this Post  Reply with Quote 
Re: Search not working at all in v.2 beta

I can search the KJV Bible with background indexing disabled.

However, when searching the MHC commentary then the spinning gear thing keeps spinning and I have to force quit MacSword.
[Nov 2, 2009 6:18:34 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male mdbergmann
Inventory
Member's Avatar

Germany
Joined: Jun 12, 2008
Post Count: 640
Status: Offline
Reply to this Post  Reply with Quote 
Re: Search not working at all in v.2 beta

However, when searching the MHC commentary then the spinning gear thing keeps spinning and I have to force quit MacSword.

The MHC is a huge module and you should prepare that indexing takes, depending on the CPU, 3 to 5 minutes.
You actually should be able to work further in another view because the indexing operation is running in it's own thread.

Manfred
----------------------------------------
[Edit 1 times, last edit by mdbergmann at Nov 3, 2009 12:58:34 AM]
[Nov 3, 2009 12:43:06 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
Posts: 19   Pages: 2   [ Previous Page | 1 2 ]
Show Printable Version of Thread  Post new Thread