mvnForum Homepage Welcome Guest  | Guest Setting  |  Register  |   Login
  Search  
Index  | Recent Threads  | Unanswered Threads  | Who's Online  | User List  | Help


»

No member browsing this thread
Thread Status: Active
Total posts in this thread: 4
Post new Thread
Author
Previous Thread This topic has been viewed 2006 times and has 3 replies Next Thread
Male timchase
Stranger




Joined: Jul 16, 2009
Post Count: 3
Status: Offline
Reply to this Post  Reply with Quote 
OSIS2mod cipher not working

I have been using osis2mod Rev 2435 and there is no difference in the generated module when the cipher switch is on or off.
Program output with the switch on is:

You are running osis2mod: $Rev: 2435 $
Adding cipher filter with phrase: abcd1234efgh5678

in either case the generated module comes up in Sword without a keyphase in the config file.

In addition I did a test to see if I could extract the data out of the modules with mod2vpl and the output in both cases is the same. Completely readable. My expectation is that the ciphered module should not be readable.

I'm running the windows versions of these programs.

I'm working with a Bible Society to show them that their bible version can be encrypted but I'm having no success in showing them that their bible can be encrypted in the SWORD program.

For what its worth. I've done extra tests with the sample kjv.xml osis file and it also when run through osis2mod with the cipher key param used does not produce an encrypted module. I've created modules using the options to create a zipped and encrypted module as well as a raw and encrypted module with the same results(not encrypted). All created test modules are readable in SWORD but do not require a key. And all created modules can have their text extracted without a key.
Am I missing something? The osis2mod does not throw any errors at all.
Thanks
----------------------------------------
[Edit 1 times, last edit by timchase at Aug 21, 2009 3:25:02 AM]
[Aug 20, 2009 1:50:41 AM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male gichurch
Regular
Member's Avatar


Joined: Apr 24, 2004
Post Count: 46
Status: Offline
Reply to this Post  Reply with Quote 
Re: OSIS2mod cipher not working

Ouch. Please post this on sword-devel. This is where all developers will read it and will be able to track down any bug (if there is one)
[Aug 23, 2009 12:52:18 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male gichurch
Regular
Member's Avatar


Joined: Apr 24, 2004
Post Count: 46
Status: Offline
Reply to this Post  Reply with Quote 
Re: OSIS2mod cipher not working

I have tested and confirm this. I have posted on sword-devel and hope that a solution will be found soon
[Aug 23, 2009 1:27:59 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male jmarsden
Stranger
Member's Avatar


Joined: Aug 23, 2009
Post Count: 2
Status: Offline
Reply to this Post  Reply with Quote 
Re: OSIS2mod cipher not working (r2435 works for me)

I have tested and confirm this. I have posted on sword-devel and hope that a solution will be found soon

I responded on sword-devel, see http://www.crosswire.org/pipermail/sword-devel/2009-August/032386.html . I can't duplicate this with r2435 (I can with r2400). Full detailed steps to reproduce would be very helpful at this point. In case it is easier to download, my little test script is also available at http://crosswire.org/~jmarsden/make-kjvfull.sh

Jonathan
[Aug 23, 2009 7:47:07 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Show Printable Version of Thread  Post new Thread