mvnForum Homepage Welcome Guest  | Guest Setting  |  Register  |   Login
  Search  
Index  | Recent Threads  | Unanswered Threads  | Who's Online  | User List  | Help


»

No member browsing this thread
Thread Status: Active
Total posts in this thread: 10
Post new Thread
Author
Previous Thread This topic has been viewed 6252 times and has 9 replies Next Thread
Male EnthusOcn
Stranger




Joined: Jun 9, 2009
Post Count: 2
Status: Offline
Reply to this Post  Reply with Quote 
confused Using e-Sword modules?

Is it possible for me to use an eSword module or convert an e-Sword module?

I don't personally like the NIV all that much, but it's so popular I like to use it in a parrallel bible so I know what other people are seeing when they read certain passages. I notice that you can buy it for e-Sword at http://estudysource.com/platform/site/product/products.aspx?pid=B0011 and I was wondering if it would be possible to use it in Linux?

Thanks everyone!
[Jun 9, 2009 5:12:15 AM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male EnthusOcn
Stranger




Joined: Jun 9, 2009
Post Count: 2
Status: Offline
Reply to this Post  Reply with Quote 
Re: Using e-Sword modules?

Oh, I understand that that e-Sword of totally different the BibleTime or the SWORD Project, I just wanted to know if I could convert.

Or if there's another way to get the NIV.
[Jun 9, 2009 6:01:06 AM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male Osk
Developer
Member's Avatar


Joined: Sep 17, 2003
Post Count: 211
Status: Offline
Reply to this Post  Reply with Quote 
Re: Using e-Sword modules?

No, there's no compatibility and to my knowledge, with the change in e-Sword's format, there's not even the possibility of conversion.
----------------------------------------
[Edit 1 times, last edit by Osk at Jun 9, 2009 12:42:58 PM]
[Jun 9, 2009 12:42:14 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male qduaty
Stranger




Joined: Sep 12, 2010
Post Count: 4
Status: Offline
Reply to this Post  Reply with Quote 
Re: Using e-Sword modules?

The new e-sword format is sqlite3. I have written a ModDrv for its Bible files, which works reliably on WinMo 6.1 (with SlideBible), and I'm willing to contribute it.
----------------------------------------
[Edit 1 times, last edit by qduaty at Sep 15, 2010 7:46:02 PM]
[Sep 13, 2010 12:45:35 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male ransom1982
Regular




Joined: Sep 28, 2007
Post Count: 75
Status: Offline
Reply to this Post  Reply with Quote 
Re: Using e-Sword modules?

qduaty, some others wrote a driver for the previous e-sword file format and were threatened with lawsuits. So, unless something changes, it probably isn't going to be possible to include it officially.
[Sep 16, 2010 3:33:26 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male qduaty
Stranger




Joined: Sep 12, 2010
Post Count: 4
Status: Offline
Reply to this Post  Reply with Quote 
Re: Using e-Sword modules?

Well, I am in Europe lol ;) There is no lawsuits horror here. And my goal was to support dozens of free Bible translations that happen to be released in (a free) sqlite3 format only. My file handler only supports free files and it does not break any protection schemes, simply because it does not know about them.

Anyway, the patch is here: http://s1010.chomikuj.pl/File.aspx?id=3582912...046&name=sword-1.diff
[Sep 18, 2010 6:13:39 AM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male pneaveill
Regular




Joined: Aug 30, 2010
Post Count: 12
Status: Offline
Reply to this Post  Reply with Quote 
Re: Using e-Sword modules?

gduaty,

The link appears to be dead
[Sep 23, 2010 7:49:52 AM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male qduaty
Stranger




Joined: Sep 12, 2010
Post Count: 4
Status: Offline
Reply to this Post  Reply with Quote 
Re: Using e-Sword modules?

Try this one:

http://s1010.chomikuj.pl/File.aspx?id=3582912...326&name=sword-1.diff
[Sep 23, 2010 4:26:30 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male Osk
Developer
Member's Avatar


Joined: Sep 17, 2003
Post Count: 211
Status: Offline
Reply to this Post  Reply with Quote 
Re: Using e-Sword modules?

Moved thread to General Discussion
[Oct 13, 2010 7:38:21 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male Osk
Developer
Member's Avatar


Joined: Sep 17, 2003
Post Count: 211
Status: Offline
Reply to this Post  Reply with Quote 
Re: Using e-Sword modules?

Adding support for sqlite3 modules wouldn't necessarily be a bad idea. But there are some issues to consider, such as significantly different ideas of versification/canon between Sword & e-Sword. We'd also need to contemplate whether/how to support other content types (dictionaries, etc.).

Supporting unencrypted e-Sword content essentially amounts to supporting user-created e-Sword content. The take-away from Jonathan Blake's BibleTech 2010 talk was that almost ALL user-created e-Sword content is essentially copyright-infringing. So it may not serve Sword's long-term goals to support this format.
[Oct 13, 2010 7:54:39 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Show Printable Version of Thread  Post new Thread