mvnForum Homepage Welcome Guest  | Guest Setting  |  Register  |   Login
  Search  
Index  | Recent Threads  | Unanswered Threads  | Who's Online  | User List  | Help


»

No member browsing this thread
Thread Status: Active
Total posts in this thread: 10
Post new Thread
Author
Previous Thread This topic has been viewed 103595 times and has 9 replies Next Thread
Male medunkt
Newbie



Australia
Joined: May 30, 2008
Post Count: 5
Status: Offline
Reply to this Post  Reply with Quote 
Book titles in French - how to change to English?

Since I installed MacSword on my iMac the drop down box with Bible book titles displays the book names in French.

A mystery, since a previous installation on my Macbook displays the book titles in English.

How can I change things so the book names are in English?

A previous thread - http://www.crosswire.org/forums/mvnforum/viewthread?thread=72 - has the solution as deleting the foreign language files in the Contents/Resources/locales.d directory.

Trouble is, I can't find the Contents/Resources/locales.d driectory ...

Can anybody help please?
[May 30, 2008 11:15:07 PM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
Male Osk
Developer
Member's Avatar


Joined: Sep 17, 2003
Post Count: 211
Status: Offline
Reply to this Post  Reply with Quote 
Re: Book titles in French - how to change to English?

Look for an options and/or settings screen in MacSword. You've set your locale to French (fr) and need to change it to something else (e.g. English (en)).

I don't use MacSword, so I can't provide better direction--perhaps one of the developers will respond with some more specific advice. But the advice in the other thread was plainly bad, so it has been deleted.
[May 31, 2008 4:45:07 AM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male medunkt
Newbie



Australia
Joined: May 30, 2008
Post Count: 5
Status: Offline
Reply to this Post  Reply with Quote 
Re: Book titles in French - how to change to English?

"You've set your locale to French (fr) and need to change it to something else (e.g. English (en)"


No, I haven't set anything. I merely installed MacSword on my new iMac. That resulted in drop-down boxes with French book titles.

As it happens I updated an older version of MacSword to version 1.3.5 on my other Mac - a Macbook Pro - this afternoon. The previous version of MacSword on the Macbook Pro had the book titles in English. Now they're in Dutch. Again, I didn't set anything - I just downloaded and installed the update.

Thanks for your advice, Osk, even though you don't apparently use MacSword yourself.

Why are you so sure the advice in the other thread was "plainly bad"? The person who wrote it was delighted at having found a solution to the problem! He described the exact files he deleted to get the drop-down boxes to function in English! If I could find those files I'd be trying the same thing he suggested.

I think you should restore the thread you deleted because (1) you don't use MacSword sothat (2) you can't have tested that person's solution. Someone who uses MacSword and knows about it might then be able to tell me where those foreign language files reside in the system.

No offense, but you haven't helped.
----------------------------------------
[Edit 2 times, last edit by medunkt at May 31, 2008 6:33:41 AM]
[May 31, 2008 6:20:50 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
Male medunkt
Newbie



Australia
Joined: May 30, 2008
Post Count: 5
Status: Offline
Reply to this Post  Reply with Quote 
Re: Book titles in French - how to change to English?

Look for an options and/or settings screen in MacSword.


By the way, there isn't one (at least that I can find) which allows you to change the language setting for the drop-down book title box.
[May 31, 2008 6:27:47 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
Male Osk
Developer
Member's Avatar


Joined: Sep 17, 2003
Post Count: 211
Status: Offline
Reply to this Post  Reply with Quote 
Re: Book titles in French - how to change to English?


Why are you so sure the advice in the other thread was "plainly bad"? The person who wrote it was delighted at having found a solution to the problem! He described the exact files he deleted to get the drop-down boxes to function in English! If I could find those files I'd be trying the same thing he suggested.

I think you should restore the thread you deleted because (1) you don't use MacSword sothat (2) you can't have tested that person's solution. Someone who uses MacSword and knows about it might then be able to tell me where those foreign language files reside in the system.


My point wasn't that the solution didn't work, but that it was solving the problem in the wrong way. The software is written so that it can have multiple locales installed, and then the user selects the correct one. It should default to English, but apparently there's something awry on your systems. All the same, there should be a setting somewhere to change to English.

There's also a fairly good chance that a 4-year old solution to a bug wouldn't work today.

I'm still hopeful that one of the MacSword devs will post an answer. If they don't by later today, I'll look for my mac, hook it up, and try to find a solution for you myself.
[May 31, 2008 2:59:54 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male Osk
Developer
Member's Avatar


Joined: Sep 17, 2003
Post Count: 211
Status: Offline
Reply to this Post  Reply with Quote 
Re: Book titles in French - how to change to English?

Okay, MacSword grabs its locale setting from the MacOS locale setting. To change this, you need to go to System Preferences and open the International panel. (The names will be different if you have localization set to something other than English.) MacSword will try to use the top locale on the list. So if it isn't English (and that's what you want) then drag English to the top. If it already IS English, I would suggest dragging something else to the top and then dragging English back into top position, just to set the value again in case something has become desynchronized.

In the event that there's a bug somewhere and this doesn't work. You can still delete the other locale settings in MacSword, which will make it default to the only available locale. To do this, locate your MacSword file (presumably in Applications). Right click the application and click Show Package Contents. A window will open showing a directory structure of the MacSword package. Navigate to Contents/Resources/locales.d. Here you will find all of the book localization files. Just move everything other than your desired locale into the trash. (I believe English (en) is the built-in default, so you can delete the whole locales.d directory in that case.

Let us know if this works for you.
[Jun 1, 2008 1:46:35 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male medunkt
Newbie



Australia
Joined: May 30, 2008
Post Count: 5
Status: Offline
Reply to this Post  Reply with Quote 
Re: Book titles in French - how to change to English?

Okay, MacSword grabs its locale setting from the MacOS locale setting. To change this, you need to go to System Preferences and open the International panel. (The names will be different if you have localization set to something other than English.) MacSword will try to use the top locale on the list. So if it isn't English (and that's what you want) then drag English to the top. If it already IS English, I would suggest dragging something else to the top and then dragging English back into top position, just to set the value again in case something has become desynchronized.


That's the solution for me, Osk. On my iMac, the top locale on my list was "Australian English". When I changed that to just plain "English", and opened up MacSword, the drop-down box with book titles was in English again and not French. Great!

So for some reason MacSword was changing Mac OSX's "Australian English" locale to "French" for its book titles! Curious....

Next, I checked my Macbook Pro. Same story, made "English" the top locale - and that's how the book titles now appear, instead of in Dutch.

Thanks very much, Osk, for taking the time to find the solution to this minor but irritating problem. Much appreciated. Merci. Bedankt.
----------------------------------------
[Edit 1 times, last edit by medunkt at Jun 2, 2008 1:21:54 AM]
[Jun 2, 2008 12:46:38 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
Male mdbergmann
Inventory
Member's Avatar

Germany
Joined: Jun 12, 2008
Post Count: 640
Status: Offline
Reply to this Post  Reply with Quote 
Re: Book titles in French - how to change to English?

Hi.

Sorry guys, I didn't know there is a forum. :|
I will show up more frequently here.

Thanks Osk for helping out.

Indeed, MacSword loops through the list of available locales in the system (changeable in System-Preferences). The first one it finds that matches one in locales.d is taken for book names.


Manfred
[Jun 12, 2008 11:30:55 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
Male stevenl
Stranger




Joined: Jul 20, 2008
Post Count: 1
Status: Offline
Reply to this Post  Reply with Quote 
Re: Book titles in French - how to change to English?

Thanks. I had exactly the same issue and the solution worked for me.

But I've now come across another related problem. While under the old locale setting, I tried to use the search function and the index used the French book names. This means that I can't search in a particular book because the search doesn't recognise the english book names. Is there a way I can get the MacSword to reindex? Perhaps delete the existing index (which I don't know how to do) and it will automatically create a new one the next time I try to search?
[Jul 20, 2008 7:53:36 AM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male mdbergmann
Inventory
Member's Avatar

Germany
Joined: Jun 12, 2008
Post Count: 640
Status: Offline
Reply to this Post  Reply with Quote 
Re: Book titles in French - how to change to English?

The index files arte stored in ~/Library/Application Support/MacSword .
Here bible books have a folder "Index-<modulename>". Delete this folder to reindex on the next search operation.


Manfred
[Jul 20, 2008 10:28:21 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
Show Printable Version of Thread  Post new Thread