mvnForum Homepage Welcome Guest  | Guest Setting  |  Register  |   Login
  Search  
Index  | Recent Threads  | Unanswered Threads  | Who's Online  | User List  | Help


»

No member browsing this thread
Thread Status: Active
Total posts in this thread: 3
Post new Thread
Author
Previous Thread This topic has been viewed 2055 times and has 2 replies Next Thread
Male edbgato
Newbie




Joined: Aug 5, 2011
Post Count: 5
Status: Offline
Reply to this Post  Reply with Quote 
confused Problem with Sword-1.6.0 and Xiphos-3.1.1 on CentOS/Gnome

I'm seeking the proper forum for fielding problems with pre-built packages, specifically Sword-1.6.0, Xiphos-3.1.1 and LibCLucene-0.9.16 for CentOS 5 with Gnome desktop.

I found the RHEL5 rpm's for Sword, Xiphos, and LibCLucene at RPMFind. They installed without error or complaint. Xiphos started as expected with the dialog to install modules. I installed the KJV bible from the crosswire repository and the Xiphos main window displayed as expected. So far, so good.

The issue I experience is there is no text showing where the bible text should be showing, in fact, there is no text in any of the xiphos text boxes. When I click the book, chapter or verse navigation controls, it causes several instances of my file browser (Nautilus) to open. Every option I set or reset in xiphos causes 3 or more instances of nautilus to open. And still no text is displayed in any of the text boxes.

Any ideas or suggestions for what to do?

Your assistance or pointers would be greatly appreciated.

Ed
[Aug 6, 2011 1:26:28 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male edbgato
Newbie




Joined: Aug 5, 2011
Post Count: 5
Status: Offline
Reply to this Post  Reply with Quote 
Re: Problem with Sword-1.6.0 and Xiphos-3.1.1 on CentOS/Gnome

<sigh> Sorry for the post.
It would appear that the multiple Nautilus instances is a problem with Xiphos-3.1.1 and Xulrunner. This has been fixed in Xiphos-3.1.3, which is only available as a pre-built package for CentOS / RHEL 6. As of this date, upgrading my linux box to CentOS 6 requires a complete reinstall of the OS, something I am not willing to do right now.
If I am wrong about my assessment, please let me know.
Ed
[Aug 6, 2011 3:20:49 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male karl
Regular
Member's Avatar


Joined: Jul 14, 2006
Post Count: 66
Status: Offline
Reply to this Post  Reply with Quote 
Re: Problem with Sword-1.6.0 and Xiphos-3.1.1 on CentOS/Gnome

the multiple Nautilus instances is a problem with Xiphos-3.1.1 and Xulrunner....If I am wrong about my assessment, please let me know.


You're quite right, though the real problem was xulrunner itself. We worked around it in Xiphos.

Xulrunner has been enough of a problem that we are disposing of it entirely. 3.1.5 is soon to be released, for which xulrunner has been replaced by webkit. By the time 4.0 comes along, I expect we will have excised all remaining xulrunner-specific code.

Whether that can be made available in CentOS, I'm not able to say. I will say that you should upgrade past 3.1.1 or 3.1.3 if at all possible. A lot has been done since then.
----------------------------------------
Project Admin, Xiphos
[Aug 7, 2011 4:35:26 PM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest    karlkleinpaste    karlkleinpaste [Link] Report threatening or abusive post: please login first  Go to top 
Show Printable Version of Thread  Post new Thread