mvnForum Homepage Welcome Guest  | Guest Setting  |  Register  |   Login
  Search  
Index  | Recent Threads  | Unanswered Threads  | Who's Online  | User List  | Help


»

No member browsing this thread
Thread Status: Active
Total posts in this thread: 3
Post new Thread
Author
Previous Thread This topic has been viewed 919 times and has 2 replies Next Thread
Male edbgato
Newbie




Joined: Aug 5, 2011
Post Count: 5
Status: Offline
Reply to this Post  Reply with Quote 
confused Compiling Sword Engine on Centos 5

Greetings Sword Fans

I'm trying to compile the Sword Engine on Centos 5.6.

My compile stops with an Error 1 around the module curlhttpd.cpp.

The ICU Development stuff mentioned in one post in this forum has been installed as well as the CLecene package, but the error persists.

Forgive the lack of compiler output as I did not realize I would join this forum when I shut down the Linux box.

I will post the output if someone is still doing Linux development on Sword. The source files appear to be last updated sometime in 2008 -2009.

Is Sword on Linux still active?

Ed
[Aug 5, 2011 8:17:16 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male Osk
Developer
Member's Avatar


Joined: Sep 17, 2003
Post Count: 211
Status: Offline
Reply to this Post  Reply with Quote 
Re: Compiling Sword Engine on Centos 5

It sounds like you need to install cURL (libcurl) or disable it in the build.

I'll also give the standard disclaimer that if you aren't planning to do some kind of development with Sword, you're probably better off installing pre-built packages of Sword and a frontend to it.
[Aug 6, 2011 3:15:38 AM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Male edbgato
Newbie




Joined: Aug 5, 2011
Post Count: 5
Status: Offline
Reply to this Post  Reply with Quote 
Re: Compiling Sword Engine on Centos 5

Thank you, Osk, for the response.
I did finally install a pre-built package, but it has issues too.
Pre-built packages for CentOS and RHEL seem real hard to find.
RPMFind does have liblucene-0.9.16, sword-1.6.0 and xiphos-3.1.1,
but I found no yum repositories that contain them....yet.
Now I need to find a support forum for the pre-built.
Thanks again
Ed
[Aug 6, 2011 12:52:11 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Show Printable Version of Thread  Post new Thread