mvnForum Homepage

Print at Jan 29, 2015 7:45:02 PM View all posts in this thread on one page
Posted by troypulk at Sep 23, 2010 11:35:37 PM
Need help with OSIS
Hello,

I'm adding red words for Jesus's words and there seems to be an error in the quotation marks that I can't seem to get around.

When I have this in the OSIS.XML:

<q who="Jesus">Permit it now, for thus it is fitting for us to fulfill all righteousness.</q>


It looks like this in Bibletime:

""Permit it now, for thus it is fitting for us to fulfill all righteousness.""

The problem is the double quotes, I only want the red ones or none at all.

After reading the OSIS 2.1.1 manual I still haven't found the answer.

I converted my KJV to OSIS and looked at this verse and the quotes appear the same but when I look at the KJV verse in Bibletime there are no quotation marks.

Does any one know whats going on?

Thanks

Posted by Osk at Sep 24, 2010 12:27:26 AM
Re: Need help with OSIS
I'm guessing what you have is actually:

"<q who="Jesus">Permit it now, for thus it is fitting for us to fulfill all righteousness.</q>"


Is that correct? If your text really has no quotation marks in CDATA, then there's a bug in BibleTime that should be reported to them.

The <q> indicates quoted text, which generally means quotation marks should be added. If you don't desire that quotation marks be added, you can add a marker="" attribute to the <q> element. With Sword, you can also turn off all <q>-generated quotation marks in a text by setting OSISqToTick=False in the module's .conf file.

Posted by troypulk at Sep 24, 2010 8:18:00 AM
Re: Need help with OSIS
No, that's not correct.

There are no quotes in the xml other than <q who="Jesus"> and </q>

I'll try this in Xiphos and see if it shows the quotes correctly, if so I'll post a bug report, then I'll try your advice to see if that fixes the problem.

Thanks

Posted by troypulk at Sep 25, 2010 1:57:06 PM
Re: Need help with OSIS
Okay,

I figured out what the problem is.

In what I'm doing I'm using osis2mod to convert a freshly made OSIS.XML and after it's converted to a module the double quotes appear.

So the error is in osis2mod, I will have to submit a bug report for it.

Posted by troypulk at Oct 5, 2010 9:27:06 PM
Re: Need help with OSIS (SOLVED)
I'm guessing what you have is actually:

"<q who="Jesus">Permit it now, for thus it is fitting for us to fulfill all righteousness.</q>"


Is that correct? If your text really has no quotation marks in CDATA, then there's a bug in BibleTime that should be reported to them.

The <q> indicates quoted text, which generally means quotation marks should be added. If you don't desire that quotation marks be added, you can add a marker="" attribute to the <q> element. With Sword, you can also turn off all <q>-generated quotation marks in a text by setting OSISqToTick=False in the module's .conf file.


Actually, this had nothing to do with osis2mod, the option suggested by Osk was the solution

setting OSISqToTick=False in the module's .conf file


Thanks