mvnForum Homepage

Print at Dec 27, 2014 4:39:38 AM
Posted by BlueSky at Jan 3, 2010 12:40:26 PM
MacSword 2.0.7 - Unable to install modules
I installed MacSword 2.0.7-290. I tried manually installing my previously downloaded modules (primarily to save server bandwidth/usage) based on the Wiki page. This did not work, meaning that after placing the modules in the path (user/library/application support/sword) MacSword crashed on restart. Then I tried the Module Installer. I selected the files to install from CrossWire. They appeared to be downloading and installing. But when I closed the Module Installer, the left top column (Modules) on the main workspace showed no modules installed. I even tried restarting MacSword.

Has anyone else had this problem? What about a solution? Any assistance would be appreciated. I'm thinking of reverting to version 1.4.4.

Thanks,
BlueSky

Posted by mdbergmann at Jan 4, 2010 9:19:50 AM
Re: MacSword 2.0.7 - Unable to install modules
Hi.

Both methods are known to work.

When you say "They appeared to be downloading and installing", what exactly does this mean?
On very rare occasions the modules are not downloaded fully. It happened once to me.
Try downloading one module via the module installer. If it worked you can select more.


Manfred

Posted by iammikeb at Jan 5, 2010 5:06:12 PM
Re: MacSword 2.0.7 - Unable to install modules
I am having the same issue.

A manual installation of modules causes MacSword to crash no matter which module I install. I have tried them one at a time to confirm this.

When I try and install a module I select "Install" from the task drop down and then click "Process Tasks". It then pops up the "Installing Modules" progress bar/window which stays open for a bit. It then closes and the module still says "Not Installed". No matter which module I try from any source I get the same results.

Posted by BlueSky at Jan 5, 2010 9:05:32 PM
Re: MacSword 2.0.7 - Unable to install modules
I am having the same issue.

A manual installation of modules causes MacSword to crash no matter which module I install. I have tried them one at a time to confirm this.

When I try and install a module I select "Install" from the task drop down and then click "Process Tasks". It then pops up the "Installing Modules" progress bar/window which stays open for a bit. It then closes and the module still says "Not Installed". No matter which module I try from any source I get the same results.


I'm having exactly this very same issue. I am unable to install any modules at all. Manual installation by placing the .swd files in the user/library/.../Sword directory causes the program to crash on restart, whether I try one at a time or not.

Also the installer function does not actually install any modules for me. I select "install" for any given module. I then click the process button. Processing appears to be working per the status bar. But when that is done, the module that was supposed to be installed still shows not installed.

Posted by mdbergmann at Jan 6, 2010 1:09:26 AM
Re: MacSword 2.0.7 - Unable to install modules
Is it possible for you to send me a crash report please?

I tried installing a module and realised that the first couple of seconds there was some traffic but that ended after a short while and no data got transferred any more.

Then 5 minutes later another module installed fine.

It could be a problem with our module server.


Manfred

Posted by iammikeb at Jan 6, 2010 5:40:10 AM
Re: MacSword 2.0.7 - Unable to install modules
I would gladly send you one but it is not actually crashing for me to send you a report. It just hangs on the progress bar / pop up for a bit and then closes.

Posted by iammikeb at Jan 6, 2010 6:20:51 AM
Re: MacSword 2.0.7 - Unable to install modules
Let me be more precise with that statement. The progress bar / pop up hangs and looks like it is processing the module but after a minute or two the progress bar / pop up closes and the module did not install. MacSword continues to run as well as the Module Manager. Nothing crashes.

Posted by mdbergmann at Jan 6, 2010 8:45:55 AM
Re: MacSword 2.0.7 - Unable to install modules
Let me be more precise with that statement. The progress bar / pop up hangs and looks like it is processing the module but after a minute or two the progress bar / pop up closes and the module did not install. MacSword continues to run as well as the Module Manager. Nothing crashes.

This crash report I actually meant for the crash that happens when modules are manually copied to the modules folder.

As for your issue. The problem here is that for some reason no data is coming though from the server any more and then the progress bar just disappears because the connection to the server just times out.
The module is not fully downloaded and thus doesn't get installed.


Manfred

Posted by iammikeb at Jan 6, 2010 9:41:55 AM
Re: MacSword 2.0.7 - Unable to install modules
It would not let me post the crash report within the code tags so I just emailed it to you. Thanks for looking.

Posted by iammikeb at Jan 10, 2010 2:37:04 PM
Re: MacSword 2.0.7 - Unable to install modules
Tried 2.1 but problem still exists for me. Thanks again for all of your hard work and for looking into it. This project is a blessing to me and many others.

Posted by mdbergmann at Jan 10, 2010 3:34:30 PM
Re: MacSword 2.0.7 - Unable to install modules
Which problem?
Does the modules still not install or does the application crash?
The module installer however should work.
If all things fail for you there is still a chance to install the modules manually:
for this the contents of the manually downloaded module's "mods.d" and "modules" folders have to be copied into the same folder structure in:
~/Library/Application Support/Sword/mods.d and
~/Library/Application Support/Sword/modules


Manfred

Posted by BlueSky at Jan 13, 2010 7:06:52 PM
Re: MacSword 2.0.7 - Unable to install modules
I completely uninstalled MacSword. And then I reinstalled. After that, I attempted to install modules using Module Manager. I still get the same lack of installation response. Unfortunately MacSword is not crashing right now and I lack crash logs.

When I click on "Edit Install Source" to see the network settings this is what is see:

Type: Remote
Name: CrossWire
Host: ftp.crosswire.org
Directory: /pub/sword/raw

When I click on the "Test Source" button, the response is "Warning. The information is not valid. Please check again."

So, possibly my ftp settings are incorrect.

Thanks for your efforts to help me resolve this issue.

Regards,
Gareth

Posted by mdbergmann at Jan 14, 2010 3:37:34 PM
Re: MacSword 2.0.7 - Unable to install modules
I completely uninstalled MacSword. And then I reinstalled. After that, I attempted to install modules using Module Manager. I still get the same lack of installation response. Unfortunately MacSword is not crashing right now and I lack crash logs.

How do you complete uninstall MacSword? Do you mean you trash the application?


When I click on "Edit Install Source" to see the network settings this is what is see:

Type: Remote
Name: CrossWire
Host: ftp.crosswire.org
Directory: /pub/sword/raw

When I click on the "Test Source" button, the response is "Warning. The information is not valid. Please check again."

So, possibly my ftp settings are incorrect.

They are correct.
This test checks for a mods.d folder on the server which in fact is there but something is wrong with this check.

I don't really know to be honest what might be wrong. Are you still not able to install a module?


Manfred

Posted by BlueSky at Jan 14, 2010 7:45:11 PM
Re: MacSword 2.0.7 - Unable to install modules
I uninstalled using App Cleaner, so all the hidden files in the Library were also removed.

I am still unable to install a module.

Posted by mdbergmann at Jan 15, 2010 1:05:04 AM
Re: MacSword 2.0.7 - Unable to install modules
I uninstalled using App Cleaner, so all the hidden files in the Library were also removed.

Hmm, that's interesting.
I'm wondering whether App Cleaner really removed all files that are mentioned in our Wiki.


Manfred

Posted by tbob32 at Jan 15, 2010 9:20:58 AM
Re: MacSword 2.0.7 - Unable to install modules
I am having the same issue.

I downloaded and installed the latest version of MacSword (first time installing any version) on Jan. 13. After starting the app I tried to download KJV using the module installer. I tried several times, it appeared that it was downloading but nothing was ever installed. I had manually created the module directory as stated in the readme.

I then manually downloaded the KJV and moved it to the dir. When I tried to restart MacSword it crashed and wanted to send the debug info to Apple. I deleted and reinstalled the module and the same happened. If I remove the module the app will start.

I am running OS X 10.6.2 on a new MacBook Pro.

Bob

Posted by mdbergmann at Jan 15, 2010 11:46:25 AM
Re: MacSword 2.0.7 - Unable to install modules
I downloaded and installed the latest version of MacSword (first time installing any version) on Jan. 13. After starting the app I tried to download KJV using the module installer. I tried several times, it appeared that it was downloading but nothing was ever installed.

Hmm, strange.
It happened to me too, very occasionally.
Normally it downloads well and if the download succeeds it actually installs the module.
As I said before, the only thing I can think of is that the connection to our server is sometimes (or in your case mostly) bad and download is canceled due to a timeout.

Does the install source refresh actually work when the download fails?


I had manually created the module directory as stated in the readme.

In which readme is that stated? You don't need to create any folders yourself.
Please check the wiki pages. All information there is more recent than in the readme.


I then manually downloaded the KJV and moved it to the dir. When I tried to restart MacSword it crashed and wanted to send the debug info to Apple. I deleted and reinstalled the module and the same happened. If I remove the module the app will start.

Please try to remove the whole "Sword" folder, let MacSword re-create it and place your downloaded KJV in there again.
Did you use the Mac module with the .swd ending?


Manfred

Posted by mdbergmann at Jan 16, 2010 6:51:58 PM
Re: MacSword 2.0.7 - Unable to install modules
Just out of curiosity. Has someone tried other install sources like Xiphos or Bible.org?
http://www.crosswire.org/wiki/Module_Repositories


Regards,
Manfred

Posted by BlueSky at Jan 17, 2010 10:59:55 AM
Re: MacSword 2.0.7 - Unable to install modules
I uninstalled using App Cleaner, so all the hidden files in the Library were also removed.

Hmm, that's interesting.
I'm wondering whether App Cleaner really removed all files that are mentioned in our Wiki.


Manfred


Manfred,

I double checked the Wiki. Yes, App Cleaner uninstalled all the files listed in the Wiki - the app itself; user/library/app support/Sword; user/library/preferences/org.crosswire.MacSword.plist.

I just completely uninstalled MacSword 2 and will give it one more try. Then I'm reverting back to the 1.x version that worked.

Thanks for your input and help.

Cheerio,
Gareth

Posted by iammikeb at Jan 17, 2010 1:12:29 PM
Re: MacSword 2.0.7 - Unable to install modules
Just out of curiosity. Has someone tried other install sources like Xiphos or Bible.org?
http://www.crosswire.org/wiki/Module_Repositories


Regards,
Manfred


I have tried the other sources and have the same results. I am in the same boat as BlueSky, going to have to go back to 1.x since 2.x will not work for me at all.

Posted by mdbergmann at Jan 17, 2010 2:09:52 PM
Re: MacSword 2.0.7 - Unable to install modules
Hmm, well.
So the module installer in MacSword 1 does work?
If so you could use that to install the modules and then can use MacSword 1 or 2 as you like.

Problem is, as long as it does work in my environment I unfortunately can't find any bug there might be.


Manfred

Posted by tbob32 at Jan 17, 2010 10:21:39 PM
Re: MacSword 2.0.7 - Unable to install modules
The dir I created was from the following section of the Readme.rtf in the docs folder in the dmg download, as follows:
-----------------------------------------------------------
Manually installing modules
The download of MacSword application does not include any modules (bibles, dictionaries, etc.). You need to download them manually from the Crosswire website. For MacSword special modules (.swd) are available which have to be placed into the folder (if the folder does not exist, please create it first):
/Users/<username>/Library/Application Support/Sword
In MacSword under Preferences->Module you need to point the Modules location folder to be the folder mentioned above and then restart. For MacSword version 1.3.1b2 and above this location is preset and it does not need to be changed. Just place your downloaded modules in the above mentioned folder.
MacSword 2 does not have this setting in preferences. This path is the only pre-defined module path in MacSword 2.
-----------------------------------------------------------

If I delete the dir and run the module installer it does create the dir and subfolders, appears to be downloading the KJV but nothing is installed. As mentioned before if I manually download the KJV and place it in that dir the app crashes on startup.

Bob

Posted by tbob32 at Jan 17, 2010 10:37:34 PM
Re: MacSword 2.0.7 - Unable to install modules
Ignore all of that, I just deleted all, rebooted, and reinstalled from fresh download. Tried the manual download and install again and it worked with two versions (KJV and MKJV). The app will start and work now. Since getting that working the module installer is now working.

Nothing I didn't try the other day, not sure what has happened or is different but all is now working. smile

Thanks for the help, let me know if there is something I can check that may help you debug,

Bob Taylor

Posted by iammikeb at Jan 18, 2010 8:42:58 AM
Re: MacSword 2.0.7 - Unable to install modules
Bob,

Thanks for the tip. Worked like a charm.

I deleted every trace of MacSword from my previous installations. There were files in several directories to be deleted. I then rebooted and reinstalled and now the Module Installer is working just fine. Thanks a million Bob.

Manfred,

Might want to suggest to users that are upgrading from 1.x to do a complete uninstall (including deleting all previous files and directories) before upgrading.

Thanks again for the work that you put into this Manfred!

Posted by mdbergmann at Jan 19, 2010 1:30:28 AM
Re: MacSword 2.0.7 - Unable to install modules
I didn't suggest this officially because there is only a few people that have problems with old MacSword 1 files.
If at all it is not necessary to delete the MacSword.plist file in Preferences and the bookmarks.plist file in AppSupport/MacSword.
Or at least copy your bookmarks and put them back in later if you don't want to loose them.
I suggested at some point because of those problems to delete the whole Sword folder content in AppSupport because the problem of the crash and possibly of the module installer are SWORD related. And the Sword AppSupport folder is the only place where any files are SWORD related.


Regards,
Manfred