mvnForum Homepage

Print at Dec 22, 2014 6:42:29 PM
Posts: 25   Pages: 3   [ 1 2 3 | Next Page ]
View all posts in this thread on one page
Posted by BlueSky at Jan 3, 2010 12:40:26 PM
MacSword 2.0.7 - Unable to install modules
I installed MacSword 2.0.7-290. I tried manually installing my previously downloaded modules (primarily to save server bandwidth/usage) based on the Wiki page. This did not work, meaning that after placing the modules in the path (user/library/application support/sword) MacSword crashed on restart. Then I tried the Module Installer. I selected the files to install from CrossWire. They appeared to be downloading and installing. But when I closed the Module Installer, the left top column (Modules) on the main workspace showed no modules installed. I even tried restarting MacSword.

Has anyone else had this problem? What about a solution? Any assistance would be appreciated. I'm thinking of reverting to version 1.4.4.

Thanks,
BlueSky

Posted by mdbergmann at Jan 4, 2010 9:19:50 AM
Re: MacSword 2.0.7 - Unable to install modules
Hi.

Both methods are known to work.

When you say "They appeared to be downloading and installing", what exactly does this mean?
On very rare occasions the modules are not downloaded fully. It happened once to me.
Try downloading one module via the module installer. If it worked you can select more.


Manfred

Posted by iammikeb at Jan 5, 2010 5:06:12 PM
Re: MacSword 2.0.7 - Unable to install modules
I am having the same issue.

A manual installation of modules causes MacSword to crash no matter which module I install. I have tried them one at a time to confirm this.

When I try and install a module I select "Install" from the task drop down and then click "Process Tasks". It then pops up the "Installing Modules" progress bar/window which stays open for a bit. It then closes and the module still says "Not Installed". No matter which module I try from any source I get the same results.

Posted by BlueSky at Jan 5, 2010 9:05:32 PM
Re: MacSword 2.0.7 - Unable to install modules
I am having the same issue.

A manual installation of modules causes MacSword to crash no matter which module I install. I have tried them one at a time to confirm this.

When I try and install a module I select "Install" from the task drop down and then click "Process Tasks". It then pops up the "Installing Modules" progress bar/window which stays open for a bit. It then closes and the module still says "Not Installed". No matter which module I try from any source I get the same results.


I'm having exactly this very same issue. I am unable to install any modules at all. Manual installation by placing the .swd files in the user/library/.../Sword directory causes the program to crash on restart, whether I try one at a time or not.

Also the installer function does not actually install any modules for me. I select "install" for any given module. I then click the process button. Processing appears to be working per the status bar. But when that is done, the module that was supposed to be installed still shows not installed.

Posted by mdbergmann at Jan 6, 2010 1:09:26 AM
Re: MacSword 2.0.7 - Unable to install modules
Is it possible for you to send me a crash report please?

I tried installing a module and realised that the first couple of seconds there was some traffic but that ended after a short while and no data got transferred any more.

Then 5 minutes later another module installed fine.

It could be a problem with our module server.


Manfred

Posted by iammikeb at Jan 6, 2010 5:40:10 AM
Re: MacSword 2.0.7 - Unable to install modules
I would gladly send you one but it is not actually crashing for me to send you a report. It just hangs on the progress bar / pop up for a bit and then closes.

Posted by iammikeb at Jan 6, 2010 6:20:51 AM
Re: MacSword 2.0.7 - Unable to install modules
Let me be more precise with that statement. The progress bar / pop up hangs and looks like it is processing the module but after a minute or two the progress bar / pop up closes and the module did not install. MacSword continues to run as well as the Module Manager. Nothing crashes.

Posted by mdbergmann at Jan 6, 2010 8:45:55 AM
Re: MacSword 2.0.7 - Unable to install modules
Let me be more precise with that statement. The progress bar / pop up hangs and looks like it is processing the module but after a minute or two the progress bar / pop up closes and the module did not install. MacSword continues to run as well as the Module Manager. Nothing crashes.

This crash report I actually meant for the crash that happens when modules are manually copied to the modules folder.

As for your issue. The problem here is that for some reason no data is coming though from the server any more and then the progress bar just disappears because the connection to the server just times out.
The module is not fully downloaded and thus doesn't get installed.


Manfred

Posted by iammikeb at Jan 6, 2010 9:41:55 AM
Re: MacSword 2.0.7 - Unable to install modules
It would not let me post the crash report within the code tags so I just emailed it to you. Thanks for looking.

Posted by iammikeb at Jan 10, 2010 2:37:04 PM
Re: MacSword 2.0.7 - Unable to install modules
Tried 2.1 but problem still exists for me. Thanks again for all of your hard work and for looking into it. This project is a blessing to me and many others.

Posts: 25   Pages: 3   [ 1 2 3 | Next Page ]