mvnForum Homepage

Print at Jul 24, 2014 8:45:51 PM
Posts: 16   Pages: 2   [ Previous Page | 1 2 ]
View all posts in this thread on one page
Posted by jmarsden at Sep 1, 2009 6:26:10 PM
Re: Errors using 'make' on Sword engine
As I think was mentioned earlier in this thread, you almost certainly need the zlib-devel RPM package installed in order to build SWORD from sources. So please try:

sudo yum install zlib-devel  # Install zlib-devel package
./usrinst.sh # Configure SWORD build environment
make # Build SWORD

and see if that gets you any further along.

Note that building SWORD using ./configure with no options supplied is probably not what you really want to do; please let the included usrinst.sh script do the work of choosing good defaults for you. Incidentally, did you read the INSTALL file, which has info on how to build SWORD in it?

One day I might look at creating SWORD RPMs, I currently am involved in creating SWORD .deb packages for Debian and Ubuntu :)

Jonathan

Posted by CiaW at Sep 3, 2009 8:36:52 AM
Re: Errors using 'make' on Sword engine
Thanks for the reply, Jonathan (and others!). I just installed zlib-devel (when I specified 'zlib-devel package' it just pulled in zlib-devel at all of 101k which I can handle...)

I ran 'make' again and got the same errors reported previously -- so I deleted that directory and uncompressed the file for a fresh start; and again the ./usrinst.sh went fine; but when I ran 'make' it came up with (new?) errors again.

Edit: I remembered about commenting the section in usrinst.sh for OPTIONS="-with-icu $OPTIONS" and did that. This time Sword installed! Yay!

Of course then when I went to install Xiphos 3.1.1 it's telling me either no sword or sword not recent enough.

However, I have wine installed with Theophilos working and I may try to figure out the eSword issues; and I've since installed Fedora 11 under a dual-boot set up so I'll install Xiphos on there since there's an rpm available.

So now I have a Xiphos issue. argh. I may look into that later, because the most recent version of Sword is now installed. -- and I very much appreciate the assistance and responses! smile

Cia W

Posted by ransom1982 at Sep 3, 2009 11:37:26 AM
Re: Errors using 'make' on Sword engine
Glad to hear things are going better. Did you do a "make install" after make? (for SWORD).

Posted by CiaW at Sep 4, 2009 10:25:50 AM
Re: Errors using 'make' on Sword engine
Yes, I did the make install after make and it told me that the sword.conf file had been created. Xiphos still isn't happy -- I think I may try BibleTime instead on this install.

Thanks again!

Posted by ransom1982 at Sep 4, 2009 11:04:44 AM
Re: Errors using 'make' on Sword engine
Well, if Xiphos can't find SWORD installed, I'd be surprised if BibleTime could. They both use the same method to find SWORD on the computer. I suggest that you take a look at this page, http://www.crosswire.org/wiki/Tutorial:Compil...nterprise_Linux_or_CentOS, and try using that script. You'll have to copy it to a text document, save it, make it executable, then run it.

Posted by ransom1982 at Oct 27, 2009 11:24:29 AM
Re: Errors using 'make' on Sword engine
For anyone who may discover this later (and for CiaW if you're still around), Xiphos and SWORD have now been packaged for CentOS. They will be available soon in the https://fedoraproject.org/wiki/EPEL package repository. Until then, they will be available here:
http://kojipkgs.fedoraproject.org/packages/xiphos/3.1.1/1.el5/ ,
http://kojipkgs.fedoraproject.org/packages/sword/1.6.0/1.el5/ , and
http://kojipkgs.fedoraproject.org/packages/clucene/0.9.21b/1.el5/

Posts: 16   Pages: 2   [ Previous Page | 1 2 ]