mvnForum Homepage

Print at Nov 26, 2014 4:28:58 AM
Posts: 13   Pages: 2   [ 1 2 | Next Page ]
View all posts in this thread on one page
Posted by Fallhallen at Jul 22, 2009 4:41:44 PM
Slackware-Current KDE 4.2 Sword 1.6.0
After installing Sword 1.5.11 I find out I actually need a higher version to work under kde 4.2. Well, I've got a bit of a problem getting it to make under Slackware-current. Got a prob with libtool here, and I can't make heads or tails out of it:

root@SlackHem:/home/fallhallen/Install/sword/sword-1.6.0# make all
Making all in lib
make[1]: Entering directory `/home/fallhallen/Install/sword/sword-1.6.0/lib'
/bin/sh ../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I../include -I../include -I/opt/sword/include -DUSE_AUTOTOOLS -DUNIX -Dunix -D__unix__ -DGLOBCONFPATH=\"/opt/sword/etc/sword.conf\" -D_FTPLIB_NO_COMPAT -O3 -ftemplate-depth-25 -DCURLAVAILABLE -I/usr/include -I/usr/lib -DUSELUCENE -MT swkey.lo -MD -MP -MF .deps/swkey.Tpo -c -o swkey.lo `test -f '../src/keys/swkey.cpp' || echo './'`../src/keys/swkey.cpp
../libtool: line 847: X--tag=CXX: command not found
../libtool: line 880: libtool: ignoring unknown tag : command not found
../libtool: line 847: X--mode=compile: command not found
../libtool: line 1014: *** Warning: inferring the mode of operation is deprecated.: command not found
../libtool: line 1015: *** Future versions of Libtool will require --mode=MODE be specified.: command not found
../libtool: line 1158: Xg++: command not found
../libtool: line 1158: X-DHAVE_CONFIG_H: command not found
../libtool: line 1158: X-I.: command not found
../libtool: line 1158: X-I../include: No such file or directory
../libtool: line 1158: X-I../include: No such file or directory
../libtool: line 1158: X-I/opt/sword/include: No such file or directory
../libtool: line 1158: X-DUSE_AUTOTOOLS: command not found
../libtool: line 1158: X-DUNIX: command not found
../libtool: line 1158: X-Dunix: command not found
../libtool: line 1158: X-D__unix__: command not found
../libtool: line 1158: X-DGLOBCONFPATH="/opt/sword/etc/sword.conf": No such file or directory
../libtool: line 1158: X-D_FTPLIB_NO_COMPAT: command not found
../libtool: line 1158: X-O3: command not found
../libtool: line 1158: X-ftemplate-depth-25: command not found
../libtool: line 1158: X-DCURLAVAILABLE: command not found
../libtool: line 1158: X-I/usr/include: No such file or directory
../libtool: line 1158: X-I/usr/lib: No such file or directory
../libtool: line 1158: X-DUSELUCENE: command not found
../libtool: line 1158: X-MT: command not found
../libtool: line 1158: Xswkey.lo: command not found
../libtool: line 1158: X-MD: command not found
../libtool: line 1158: X-MP: command not found
../libtool: line 1158: X-MF: command not found
../libtool: line 1158: X.deps/swkey.Tpo: No such file or directory
../libtool: line 1158: X-c: command not found
../libtool: line 1211: Xswkey.lo: command not found
../libtool: line 1216: libtool: compile: cannot determine name of library object from `': command not found
make[1]: *** [swkey.lo] Error 1
make[1]: Leaving directory `/home/fallhallen/Install/sword/sword-1.6.0/lib'
make: *** [all-recursive] Error 1

Maybe someone can translate this for me? Not sure what I need to do here.

Thanx

-Fallhallen

Posted by ransom1982 at Jul 24, 2009 1:56:25 PM
Re: Slackware-Current KDE 4.2 Sword 1.6.0
Sorry if this is an elementary question, but did you run usrinstall.sh or configure before make?

Matthew

Posted by Fallhallen at Jul 27, 2009 2:50:08 PM
Re: Slackware-Current KDE 4.2 Sword 1.6.0
I believe I just ran ./configure

Posted by Fallhallen at Jul 30, 2009 10:42:04 AM
Re: Slackware-Current KDE 4.2 Sword 1.6.0
What happened to the support team? Don't think they were raptured and we all got left here with the lawyers and politicians.

Posted by ransom1982 at Jul 30, 2009 12:40:23 PM
Re: Slackware-Current KDE 4.2 Sword 1.6.0
Since you're trying to install BibleTime, I suggest you ask this question on the BT users' mailing list. This forum is visited fairly infrequently I'm afraid.

I would also recommend that you run usrinst.sh rather than configure, although if you just ran configure, it would be helpful to know what options (if any) you gave it. Also, are you able to successfully compile other packages?

Matthew

Posted by Fallhallen at Jul 31, 2009 10:04:21 AM
Re: Slackware-Current KDE 4.2 Sword 1.6.0
I ran usrinst.sh, it did not help. I did not include any options with configure. And yes I am able to install other packages. But which 'packages' are you referring? That is a rather broad and vague question.

Posted by ransom1982 at Jul 31, 2009 9:06:15 PM
Re: Slackware-Current KDE 4.2 Sword 1.6.0
I didn't ask if you were able to install other packages, I asked if you were able to compile other packages. Specifically, C++ programs using autotools.

I did some googling for you (as I've never seen anything like this myself). It appears to be caused by either a) a newer version of libtool on your system than was used to create the tar.gz or b) two separate versions of libtool on your system.

One possible recommendation is to run ./autogen.sh, then ./configure then make. I would recommend that you look carefully at the configure options, as the defaults may very well not be what you want (although that's unrelated to this problem).

Posted by Fallhallen at Aug 3, 2009 2:24:58 PM
Re: Slackware-Current KDE 4.2 Sword 1.6.0
fallhallen@SlackHem:~/Install/sword/sword-1.6.0$ ./autogen.sh
*** Sword build system generation
*** Recreating libtool
libtoolize
You should update your `aclocal.m4' by running aclocal.
*** Recreating aclocal.m4
aclocal
./autogen.sh: line 13: aclocal: command not found
*** Recreating configure
./autogen.sh: line 18: autoheader: command not found
./autogen.sh: line 19: autoconf: command not found
*** Recreating the Makefile.in files
./autogen.sh: line 23: automake: command not found

fallhallen@SlackHem:~$ ls /var/log/packages/ |grep libtool
libtool-1.5.26-i486-1


Must be the first solution? My version is too new? I really don't want to downgrade.

Posted by ransom1982 at Aug 3, 2009 3:02:13 PM
Re: Slackware-Current KDE 4.2 Sword 1.6.0
you need to install aclocal, autoconf, and automake. However, it appears that it at least re-created libtool. Did you try running configure and make after this?

Posted by Fallhallen at Aug 3, 2009 8:54:32 PM
Re: Slackware-Current KDE 4.2 Sword 1.6.0
you need to install aclocal, autoconf, and automake. However, it appears that it at least re-created libtool. Did you try running configure and make after this?



Installed the aforementioned packages, re-ran ./autogen.sh:

*** Sword build system generation
*** Recreating libtool
libtoolize
*** Recreating aclocal.m4
aclocal
/usr/share/aclocal/nspr.m4:8: warning: underquoted definition of AM_PATH_NSPR
/usr/share/aclocal/nspr.m4:8: run info '(automake)Extending aclocal'
/usr/share/aclocal/nspr.m4:8: or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
*** Recreating configure
*** Recreating the Makefile.in files

Then I ran ./configure: everything looked good, so I ran make. Got the same errors as reported in the first post of this message.

Posts: 13   Pages: 2   [ 1 2 | Next Page ]