mvnForum Homepage

Print at Jul 26, 2014 12:14:27 AM
Posted by Chad at Mar 11, 2009 12:48:18 PM
rose   Install help
Following instructions here:

http://www.crosswire.org/sword/develop/swordapi/

Getting error on "make" step

root@server [~/sword]# make
Making all in lib
make[1]: Entering directory `/root/sword/lib'
if /bin/sh ../libtool --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -I. -I. -I../include -I../include -DUSE_AUTOTOOLS -DUNIX -Dunix -D__unix__ -DSWICU_DATA=\"/usr/lib64/sword/1.5.11.99_icu_2.1\" -D_FTPLIB_NO_COMPAT -D_ICU_ -DUSBINARY -g3 -O0 -Wall -Werror -D_ICU_ -ftemplate-depth-25 -DCURLAVAILABLE -MT utilstr.lo -MD -MP -MF ".deps/utilstr.Tpo" -c -o utilstr.lo `test -f '../src/utilfuns/utilstr.cpp' || echo './'`../src/utilfuns/utilstr.cpp; \
then mv -f ".deps/utilstr.Tpo" ".deps/utilstr.Plo"; else rm -f ".deps/utilstr.Tpo"; exit 1; fi
g++ -DHAVE_CONFIG_H -I. -I. -I../include -I../include -DUSE_AUTOTOOLS -DUNIX -Dunix -D__unix__ -DSWICU_DATA=\"/usr/lib64/sword/1.5.11.99_icu_2.1\" -D_FTPLIB_NO_COMPAT -D_ICU_ -DUSBINARY -g3 -O0 -Wall -Werror -D_ICU_ -ftemplate-depth-25 -DCURLAVAILABLE -MT utilstr.lo -MD -MP -MF .deps/utilstr.Tpo -c ../src/utilfuns/utilstr.cpp -o utilstr.o
../src/utilfuns/utilstr.cpp:26:28: unicode/utypes.h: No such file or directory
../src/utilfuns/utilstr.cpp:27:26: unicode/ucnv.h: No such file or directory
../src/utilfuns/utilstr.cpp:28:29: unicode/ustring.h: No such file or directory
../src/utilfuns/utilstr.cpp:29:27: unicode/uchar.h: No such file or directory
../src/utilfuns/utilstr.cpp:31:28: unicode/unistr.h: No such file or directory
../src/utilfuns/utilstr.cpp:32:30: unicode/translit.h: No such file or directory
make[1]: *** [utilstr.lo] Error 1
make[1]: Leaving directory `/root/sword/lib'
make: *** [all-recursive] Error 1


Just to confirm, this install step is to get the web interface installed on the server correct? That's actually what I'm trying to accomplish so I can add the software to my Christian forum for members to utilize.

Thanks for your help.


PS: what's with the devil post icon in the forum???

Posted by Sunrise7 at Apr 18, 2011 2:42:06 AM
smile   Re: Install help
It is a small point, yet, for clarity ..
If you roll your pointer over the (red face icon, unhappy), you may note that it is for the purpose of "Reporting threatening content to the Administrator". While that instance will hopefully never happen on this forum, between contributors or between contributors towards moderators or administrators .. such DOES happen too often on many forums, in spite of the posted Rules against it.

The option is likely a feature of the mvnForum package, in use, and its removal or change would likely require your or mine comments directed specifically to those developers, or, as a request to the administrator here to forward on to them.

Personally, I would like to have a (Happy Face) icon added, which would allow the membership to "vote" a sign of thanks and support for worthy posts which are very informative and relevant .. and I don't see that option here, unless one is in the midst of posting a Reply, like this one, and want to add one to their comment, during a Preview.