mvnForum Homepage

Print at Dec 18, 2014 6:41:10 PM View all posts in this thread on one page
Posted by ebgd7 at Mar 18, 2005 1:02:29 PM
shock   Problems with osis2mod and Sword for Windows rendering - serious bug report
Hi!
Following advice given in this thread I've encoded part of the New Testament for Polish Bible Warszawsko-Praska. Trying hard to encode the printed original in OSIS representing all the details I've encountered some quite serious problems.

Following strong request of not posting cult material, copyrighted especially I've created neutral OSIS test file explaining all the problems I've encountered. This file is available on my web page http://panda.bg.univ.gda.pl/~krzbia/test.osis.xml .
Here I'll list all the problems found together with brief explanations

  • paragraph markers <p> and </p> placed outside of verse tags are not parsed correctly by osis2mod, that is closing tag is not included. This problem was confirmed earlier by Osk, but still it is a unsolved problem sad
  • a note containing reference spanning a fragment of text in which there is <p> and not </p> results in a popup note containing some RTF rubbish sad
  • construct <div><title>A title</title>... placed at the beginning of the chapter couses the title to be ignored sad
  • construct <div><title>1 title</title><div><title>2 title</title> on the beginning of the chapter - the '1 title' is ignored sad
  • construct <div><title>1 title</title><div><title>2 title</title><div><title>3 title</title> at the beginning of the chapter - only '3 title' is shown, and all the verses from the inner <div> are joined together as one?! sad
  • construct <div><title>1 title</title><div><title>2 title</title> in the middle of the chapter results in the titles presented in the wrong sequence sad
  • construct <div><title>1 title</title><div><title>2 title</title><div><title>3 title</title> in the middle of the chapter couses the titles to be presented in the order 3 1 2. crying
  • A notes within <title></title> are not rendered as popups but included in the title confused


All this cases are present in the test file and can be shown in the Sword.
Important! The tests I've performed were done using lates osis2mod and Sword for Windows v 1.5.8pre3.

Greetings and really looking for help.
Christopher

Posted by ebgd7 at Mar 18, 2005 3:22:50 PM
biggrin   Re: Problems with osis2mod and Sword for Windows rendering - serious bug report
Small explanation:
By "serious bug report" I've meant "serious report" not "serious bug" biggrin
Sorry for confusion.

Posted by ebgd7 at Apr 2, 2005 1:02:31 PM
sad   Re: Problems with osis2mod and Sword for Windows rendering - serious bug report
New problem discovered - the test.osis file updated.
This time the problem is with the introductions.
The introduction is not rendered properly if it includes paragraphs. (Introduction with no paragraphs is rendered properly...)

Posted by dmsmith at Oct 17, 2006 9:41:18 AM
Re: Problems with osis2mod and Sword for Windows rendering - serious bug report
I think this is fixed with the latest rendition of osis2mod.

The problem was that spanning paragraphs is not something that can be easily handled by the frontends. Thus, <p> and </p> are each changed to <lb/> by osis2mod. The SWORD api 1.5.9 was changed to handle <lb/> correctly in each of the filters.