mvnForum Homepage

Print at Sep 15, 2014 8:00:06 PM View all posts in this thread on one page
Posted by ebgd7 at Jan 15, 2005 3:49:35 PM
confused   Problems with references and notes in IMP/Osis file
In the .IMP file with osis tags I have the following tag:
<note type="explanation">See: <reference osisRef="Isa.8.14">Isa 8,14 </reference>.</note>
Then after import (imp2vs) in Sword I have *(n6) clickable refrence showing empty box.
Can anyone help me? How to create proper footnotes in the bible modules? How to create proper clickable references?

Greetings,
Chris.

Posted by ebgd7 at Jan 16, 2005 6:49:23 AM
shock   Re: Problems with references and notes in IMP/Osis file
Once again partly self support forum...
From the code reverse engineering it looks like the osis notes are simply not working. So putting:
<note>A simple note without a type</note>
in verse number 1.
produces: "*n1" which opens empty box upon pointing with cursor.
Is this correct? (as of Sword 1.5.6 for Windows?)

putting:
<note swordFootnote="a note">Simple note</note>

produces: "*n1.a note" - also producing empty box.

So, what should I do to create proper footnotes in osis?!?! Please help!!

Another thing that does not work are the osisRef's in <reference> tag.
Putting:
<reference osisRef="John.2.3">John 2</reference>

Results in the reference to John 2 and not John 2:3!!! So basicly osisRef's are ignored!.

Posted by Osk at Jan 16, 2005 1:01:31 PM
Re: Problems with references and notes in IMP/Osis file
First, note that you are not promised full OSIS support in Sword 1.5.6. OSIS support will improve in Sword 1.5.8, which were working on presently. If you find behavior you believe is incorrect, please bring it to our attention so that we may evaluate it and consider how to fix the problem (or tell you that the behavior is correct, if it is).

Also note that osis2mod does more to OSIS files than simply import them to the correct database positions (which is the behavior you will always get with imp2vs). I don't believe any of that should affect <note> elements, however. But osis2mod is really the only tool we will support for OSIS import. I'll try to remember to post a windows binary this week.

Once again partly self support forum...
From the code reverse engineering it looks like the osis notes are simply not working. So putting:
<note>A simple note without a type</note>
in verse number 1.
produces: "*n1" which opens empty box upon pointing with cursor.
Is this correct? (as of Sword 1.5.6 for Windows?)


This is correct syntax for a note and it works fine in more recent builds of the SWORD Project for Windows. (So it's probably just lack of support back in 1.5.6.)


Another thing that does not work are the osisRef's in <reference> tag.
Putting:
<reference osisRef="John.2.3">John 2</reference>

Results in the reference to John 2 and not John 2:3!!! So basicly osisRef's are ignored!.


That may be. I think we had some trouble with the RTF dealing with <href> tags and we might not be able to link to a different reference from what is written in English. (Can anyone else confirm that?) Our roadmap for fixing this bug is to change rendering engines, and there's no ETA on that. It should work fine in all other frontends.

Posted by ebgd7 at Jan 16, 2005 11:55:27 PM
smile   Re: Problems with references and notes in IMP/Osis file
First, note that you are not promised full OSIS support in Sword 1.5.6. OSIS support will improve in Sword 1.5.8, which were working on presently.
[...]
I'll try to remember to post a windows binary this week.

Sure noone promised the full OSIS support, but it was stated that it should be used instead of other tag systems. Once I've seen the current source code I've realised that the support is not complete - I'm not complaining - the product is already great - just stating the facts. It is really great news that new Windows version binaries will be available. I've tried to compile from source using BC6 without success...


Another thing that does not work are the osisRef's in <reference> tag.
Putting:
<reference osisRef="John.2.3">John 2</reference>

Results in the reference to John 2 and not John 2:3!!! So basicly osisRef's are ignored!.


That may be. I think we had some trouble with the RTF dealing with <href> tags and we might not be able to link to a different reference from what is written in English. (Can anyone else confirm that?) Our roadmap for fixing this bug is to change rendering engines, and there's no ETA on that. It should work fine in all other frontends.

So this still remains a problem - not very serius one as workaround is available.

Thank You for quick answer, and keep the good work - I'll also work hard on new modules.

Greetings,
Christopher

Posted by ebgd7 at Feb 11, 2005 5:07:29 AM
shock   Re: Problems with references and notes in IMP/Osis file
OK, finally corrected.
Its time to confess: my fault, my fault...
It looks like I forgot about very important configuration variable in .conf:
GlobalOptionFilter=OSISFootnotes

sad shame on me...crying

So problem solved. But still looking for osis2mod for windows based on 1.5.8pre2.
Greetings
Chris

Posted by hermeneutes at Feb 17, 2005 7:35:50 AM
Re: Problems with references and notes in IMP/Osis file
But still looking for osis2mod for windows based on 1.5.8pre2.


Me, too. :)

Piotr