mvnForum Homepage


Posted by ebgd7 at Feb 21, 2005 9:09:11 AM
confused   Strange behaviur of osis2mod with paragraphs.
Hi there!
Firs of all thank You for releasing osis2mod for windows. Ok, now back to the problem. I have the following osis file:


<?xml version="1.0" encoding="utf-8"?>
<osis xmlns="http://www.bibletechnologies.net/2003/OSIS/namespace" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.bibletechnologies.net/2003/OSIS/namespace http://www.bibletechnologies.net/osisCore.2.0.1.xsd">
<osisText osisIDWork="NWT" osisRefWork="bible" xml:lang="en-US">
<header>
<work osisWork="NWT">
<title>New World Translation</title>
<type type="OSIS">Bible</type>
<identifier type="OSIS">Bible.en.NWT</identifier>
<refSystem>Bible</refSystem>
</work>
<work osisWork="Bible">
<type type="OSIS">Bible</type>
<refSystem>Bible</refSystem>
</work>
</header>
<div type="bookGroup" osisID="ot">
<div type="book" osisID="Gen">
<div type="chapter" osisID="Gen.1" >
<p>
<verse sID="Gen.1.1" osisID="Gen.1.1"/>
removed
<verse eID="Gen.1.1"/>
<verse sID="Gen.1.2" osisID="Gen.1.2"/>
removed
<verse eID="Gen.1.2"/>
</p><p>
<verse sID="Gen.1.3" osisID="Gen.1.3"/>
removed
<verse eID="Gen.1.3"/>
</p><p>
<verse sID="Gen.1.4" osisID="Gen.1.4"/>
removed
<verse eID="Gen.1.4"/>
<verse sID="Gen.1.5" osisID="Gen.1.5"/>
removed
<verse eID="Gen.1.5"/>
<verse sID="Gen.1.6" osisID="Gen.1.6"/>
removed
<verse eID="Gen.1.6"/>
</p>
</div> <!-- chapter-->
</div>
</div>
</osisText>
</osis>


As You notice the paragraph marks are placed outside verses. From the OSIS point of view it should work fine, but it does not. There are three problems (possibly connected):
1) Looking at the resulting module at 'ot' file I can see that verses 2,3 and six are duplicated!
2) There are no closing paragraph tags (</p>)
3) finally, Sword for windows displays rubbish - some rtf formatting tags I do not understand...

I'm I doing something wrong here? Please help!