mvnForum Homepage


Posted by tcrawfordjakarta at Jun 9, 2011 6:49:23 AM
Re: Compiling sword on Fedora 15
I finally got sword to compile by using a cmake compile. I found you could turn off the -Werror and -Wall and -g3 flags by not using a debug build when using cmake. I picked up this info from the cmake README file

* CMAKE_BUILD_TYPE - If this is given the value of "Debug" then the default SWORD debugging flags (-g3 -Wall -Werror -O0) will be enabled. If this is unspecified or any value other than "Debug" then the flag -O3 will be enabled.

I tried to set the g++ complier flags from the environment command export CXXFLAGS=O3, but you still get the Werror when you are trying to do a regular compile.

The problem of changing all the files is that there are lots of -Wall errors in the sword source.

Anyway, I got sword installed and Bibletime is up and running fine.

Tom