mvnForum Homepage


Posted by dration7 at May 29, 2011 8:16:49 PM
sad   Compiling SWORD engine
Hi there

I'm trying to compile the SWORD engine both on my mac and linux machines. I'm having the same problem on both. I am aware someone asked this or a similar question before, but I followed the forum for as long as i could understand and plus it was written back in '09 and im not sure what has changed since then.

My apologies, though, if this requieres a repeat solution.

So here's the deal:
I downloaded the zip file (v. 1.6.2) and unzipped it.
I then read the README and INSTALL files which instructed the following-

./usrinst.sh
make
su
make install

If you have never installed sword before and/or are happy with a default
configuration, you may wish to type:

make install_config


I tried both and I keep getting errors while "making":

make[1]: *** [swmgr.lo] Error 1
make: *** [all-recursive] Error 1


This actually comes after a great deal of errors dealing with file "utf8translliterator.h"

I also tried running ./userinstal.sh before trying "make" or "make install", but with both make commands, I still get those errors. 
This is a bit frustrating to say the least, but I'll be glad when I get get past this b/c I think this SWORD engine is a great tool for developers. 

Any help is really appreciated. 
Don