mvnForum Homepage


Posted by mdbergmann at Jan 15, 2010 11:46:25 AM
Re: MacSword 2.0.7 - Unable to install modules
I downloaded and installed the latest version of MacSword (first time installing any version) on Jan. 13. After starting the app I tried to download KJV using the module installer. I tried several times, it appeared that it was downloading but nothing was ever installed.

Hmm, strange.
It happened to me too, very occasionally.
Normally it downloads well and if the download succeeds it actually installs the module.
As I said before, the only thing I can think of is that the connection to our server is sometimes (or in your case mostly) bad and download is canceled due to a timeout.

Does the install source refresh actually work when the download fails?


I had manually created the module directory as stated in the readme.

In which readme is that stated? You don't need to create any folders yourself.
Please check the wiki pages. All information there is more recent than in the readme.


I then manually downloaded the KJV and moved it to the dir. When I tried to restart MacSword it crashed and wanted to send the debug info to Apple. I deleted and reinstalled the module and the same happened. If I remove the module the app will start.

Please try to remove the whole "Sword" folder, let MacSword re-create it and place your downloaded KJV in there again.
Did you use the Mac module with the .swd ending?


Manfred