mvnForum Homepage


Posted by CiaW at Aug 23, 2009 5:17:03 PM
Errors using 'make' on Sword engine
Hi all! I'm somewhat new to linux, and used to use (and loved) eSword on Windows. I have a laptop running Fedora 7 and I've installed or tried both gnomesword (I know it's now Xiphos) and BibleTime. I recently got a new desktop pc on which I've installed CentOS 5.3 and there are no Xiphos / BibleTime / gnone sword rpm packages available for them.

I'm not sure if it'd be safe to install, say a Fedora 10 rpm on my CentOS system (I could ask in their forum...); but I thought I'd try to just download and install the source packages. From a previous attempt I know that Xiphos requires version 1.5 or later of Sword; so I downloaded that first and also installed GCC and after an error discovered I also needed gcc-c++ which I've also installed. The ./configure command went just fine, then when I used the 'make' command it ran for a few moments and returned a message of
make: *** [all recursive] Error 1
for versions 1.6.0 with another message before that.

Since version 1.5.x would be acceptable I downloaded v1.5.11 then v1.5.10 after 11 failed, and on both of them I got the same error message as follows:
./lib/.libs/libsword.so: undefined reference to 'compress' (next line same reference to) 'gzdopen', 'gzerror', 'gzread', 'uncompress'
Then:
 collect2: ld returned 1 exit status 

 make[1]: *** [buildtest] Error 1
make[1]: Leaving directory `/usr/share/sword-1.5.10'
make: *** [install-recursive] Error 1

Before I throw in the towel on this endeavor and install wine and esword; I thought I'd post here and request help. I even had a bright idea that I might try to figure out how to create an rpm for CentOS; but first I need to be able to install it locally. sad

Do you need to know what versions of gcc-c++ I'm using or anything? My PC is an AMD phenom triple core; 2 gig of ram running CentOS 5.3
* update* I visited the centos forums and found they have a preview of gcc ver 4.3 available as well as gcc43-c++; I suspect that is the newest version of gcc ? At any rate I installed that and ran the 'make' command in the directory 1.5.11 and 1.5.10 and got the same error messages as above.

Any advice would be appreciated-- I'm not a programmer, just trying to follow the steps in the install and readme files! Thanks.

Cia W