mvnForum Homepage


Posted by clarval at Aug 21, 2009 12:07:12 PM
confused   Re: MacSword 2 beta announcement

Right, for some reason the modules at application level are not loaded.
Hmm, need to debug that.
However that neither works in MacSword 1.4.3 here.

For me, MacSword 1 opens the Modules in /Applications/MacSword/Modules (MacSword 1 is at "/Applications/MacSword/MacSword 1.app" since I downloaded MacSword 2β as MacSword.app)

Ok, you have set this as the module path in MacSword preferences.

I don't remember doing that; is it possible that this preference was the default some time?

MacSword 2 has a fix path which is the one in "Application Support".
The reason for this is that we agreed to this path as other applications like BibleDesktop and BibleTime also use this path for module lookup.

That sounds reasonable. I haven't tried BibleDesktop and BibleTime – do they also use .swd files, or just the standard unix directory structure? Then it might be a sensible choice to declare .swd deprecated?

If you move away "~/Library/Application Support/Sword" and start MacSword, does it crash?

It does not crash unless .swd modules are in that directory.

Which ones?

Did you try adding one, start MacSword and see if it crashes. If not, put another one in, if yes, move the module out and try another one until it is clear which of the modules are causing trouble.

As I said before:
I tried different modules – one at a time –, including GerHfa2002, Wulfila, KJV, Afr1953).


I think that at least one of these would have to have worked (esp. KJV seems to be quite a classical module)?


I'm using .swd modules, too and this is working. The only thing I can imagine is that it is a module that is causing the crash when MacSword is trying to load it.
So we need to find out in your case which one it is.


It certainly is not a single module. I've just redownloaded the .swd file for KJV and unpacked it freshly to ~/Library/Application Support/Sword – and the programme crashed; sorry. Should I try one of the modules that work for you?

Cheers,
clarval