mvnForum Homepage


Posted by Yapper at Nov 26, 2008 4:19:03 AM
Re: Why doesn't my comment work ?
Thank you for your answer... I've tested many possibilities today...

First : Without Compressing

I've used "RawCom" for the ModDrv

Content of the file : mycomment.conf


[Mycomment]
DataPath=./modules/comments/rawcom/mycomment/
ModDrv=RawCom
SourceType=OSIS
Lang=en
Description=My own Comment
About=Mes commentaires personnels...
SwordVersionDate=2008-11-26


In the terminal :
osis2mod ~/.sword/modules/comments/rawcom/mycomment ~/mycomment.xml


Second : With Compressing

I've changed the file .conf and use "zCom" for the ModDrv because "zCom" is for compressed commentaries...
Wiki - Conf Files

File mycomment.conf


[Mycomment]
DataPath=./modules/comments/zcom/mycomment/
ModDrv=zCom
BlockType=BOOK
SourceType=OSIS
CompressType=ZIP
Lang=en
Description=My own Comment
About=Mes commentaires personnels...
SwordVersionDate=2008-11-26


(My mycomment.xml is still the same)

In the terminal :
osis2mod ~/.sword/modules/comments/zcom/mycomment ~/mycomment.xml 0 2 4


2 to compress in ZIP format
4 to use books for the blockType

But the problem persist... Maybe the syntax of the file XML is false or the compilation doesn't work.
In addiction I think I use the traditionnal syntax for the terminal also the compilation should work...
I've tested mycomment.conf with a "true" comment (bring in Internet but compresed) and it works. It think the problem isn't in the file .conf... I can see informations about mycomment if I click... I might work.
If you see a mistake in the XML file... Tell to me