mvnForum Homepage

Posted by QueenGeek at Aug 3, 2008 5:43:00 AM
Need Help with Module Utilities
Hello everyone.

I'm another newbie. I am attempting to create an OSIS module for import into Sword and have already encountered difficulties. I downloaded the utility executables from here:

I downloaded an OSIS formatted World English Bible to use to learn how to use the utilities. I first ran the OSIS validation and it passed. Yeah!

However, I have run into a problem using the osis2mod.exe utility. If I run in a DOS prompt, I get the error message, "This application has failed to start because ICUDT40.DLL was not found. Re-installing the application may fix this problem." If I try running in a cygwin shell, it simply does nothing and returns to the command prompt, even if I run the utility with no parameters. I would have expected the utility to print out the usage information and then die. I get the same results when running other utilities as well.

I am running Windows XP 64-bit. I have not encountered problems running apps compiled on XP 32-bit, so I don't *think* this is the problem.

But... in that event, I also tried downloading all the source from SVN using the instructions here:

Downloading worked (note I downloaded both the sword API AND the utilities -- so I did get the osis2mod.cpp, etc files). However, the compilation instructions on this web page do not work. The instructions say to use "./", which is standard for Linux apps. Fine I can deal with that. But, there is no "./" in the SVN repository -- at least when I did the check out, I got none for either the API or the utilities. Have the instructions perhaps changed and the web site just hasn't been updated???

My preference would be to get the executables working without recompilation, but any help would be appreciated!!!